华为oj初级 合并表记录

描述
数据表记录包含表索引和数值。请对表索引相同的记录进行合并,合并后表记录为相同索引表的数值求和

函数说明:
public int mergeRecord(List oriList, List rstList)
数据表记录包含表索引和数值。请对表索引相同的记录进行合并,合并后表记录为相同索引表的数值求和。

@param oriList 原始表记录。 以List方式存放,TableRecord定义见TableRecord.java,
调用者无需对leRecord.java做任何修改
@param rstList 合并后的表记录 , 以List方式存放
@return 返回合并后表的个数

知识点 栈
运行时间限制 10M
内存限制 128
输入
先输入键值对的个数
然后输入成对的index和value值,以换行符隔开
输出
输出合并后的键值对(多行)
样例输入 4 0 1 0 2 1 2 3 4
样例输出 0 3 1 2 3 4

#include<iostream>    
#include<vector>    
#include<string>    
#include<algorithm>  
#include<cmath>  
#include<unordered_map>
using namespace std;

int main(){
    int n;
    cin >> n;
    int index, val;
    unordered_map<int, int> map;
    for (int i = 0; i < n; i++){
        cin >> index >> val;
        if (map.find(index) == map.end()){
            map[index] = val;
        }
        else{
            map[index] += val;
        }
    }
    unordered_map<int, int>::iterator it=map.begin();
    for (; it != map.end(); it++){
        cout << it->first << endl<< it->second << endl;
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值