华为oj 按字节截取字符

描述
编写一个截取字符串的函数,输入为一个字符串和字节数,输出为按字节截取的字符串。但是要保证汉字不被截半个,如”我ABC”4,应该截为”我AB”,输入”我ABC汉DEF”6,应该输出为”我ABC”而不是”我ABC+汉的半个”。

接口说明
原型:public String cutString(String s, int length)

知识点 字符串
运行时间限制 10M
内存限制 128
输入
输入待截取的字符串及长度
输出
截取后的字符串
样例输入 我ABC汉DEF 6
样例输出 我ABC

#include<iostream>  
#include<string>  
using namespace std;  
int main()  
{  
    string s;  
    int n,flag=0;  
    cin>>s>>n;    
    unsigned int c1,c2;  
    for(int i=0;i<s.size();i++)  
    {     
        c1=s[i];  
        c2=s[i+1];  
        if(c1>128&&c2>128)  
            {  
                i++;  
                flag=1;//如果相邻两个字符组合是汉字标志1  
            }  
        else  
            flag=0;  
        if(i>n-1)  
            break;  
        else  
        {  
            if(flag)  
               cout<<s[i-1]<<s[i];//如果是汉字,输出两个字符  

            else  
               cout<<s[i];  
        }     
    }  
    //system("pause");  
    return 0;  
}
#include<iostream>
#include<string>
using namespace std;

int main(){
    string str;
    while(cin>>str){
        int bit;
        cin>>bit;        
        for(int j =0;j<bit;++j)
            cout<<str[j];
        cout<<endl;
    }    
    return 0;
}
#include<iostream>
#include<string>
#include<algorithm>
using namespace std;
int main(){
    string s;
    int n;
    while(cin>>s){
        cin>>n;
        int count=0;
        for(int i=0;i<s.size();i++){
            if(isalpha(s[i])){
                count++;
            }else{
                count+=2;
            }

            if(count==n){
                string str=s.substr(0,i+1);
                cout<<str<<endl;
                break;
            }else if(count>n){
                string str=s.substr(0,i);
                cout<<str<<endl;
                break;
            }
        }
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值