北大暑假训练计划—POJ1013 Counterfeit Dollar(C语言)

                                                     Counterfeit Dollar

Description

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.
Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs
one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.
By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.
Input

The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A--L. Information on a weighing will be given by two strings of letters and then one of the words ``up'', ``down'', or ``even''. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even.
Output

For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined.

Sample Input

1
ABCD EFGH even
ABCI EFJK up
ABIJ EFGH even

Sample Output

K is the counterfeit coin and it is light.
 
//题目大意:总共有12枚硬币,其中只有一枚是假币,现在称三组硬币,每组两堆,每堆硬币的数目相同,判断出哪枚硬币是假币,假币是偏轻还是偏重
#include<stdio.h>
#include<string.h>
#include<math.h>
int main()
{
    int n,a[12],i,j,len,x,y,z,max,m;
    char s1[12],s2[12],s3[12];
    scanf("%d",&n);
    while(n--)
    {  
        memset(a,0,sizeof(a));
        for(i=0;i<3;i++)
        {
        scanf("%s %s %s",s1,s2,s3);
        len=strlen(s1);
        if(strcmp(s3,"even")==0)        //如果是even说明这一组全部是真币,给真币赋值10.
        {       
        for(j=0;j<len;j++)
        {
        x=s1[j]-'A';
  if(a[x]!=10)
        a[x]=10;
        y=s2[j]-'A';
  if(a[y]!=10)
        a[y]=10;
        }
        }
    else if(strcmp(s3,"up")==0)     //当up时,说明左边重右边轻,所以给左边还没判断是真币的硬币重量+1,右边硬币1;
        {
        for(j=0;j<len;j++)
        {
        x=s1[j]-'A';
        if(a[x]!=10)
        a[x]=a[x]+1;
        y=s2[j]-'A';
        if(a[y]!=10)
        a[y]=a[y]-1;
        }
        }
        else if(strcmp(s3,"down")==0)   //当down时,说明左边轻右边重,所以给右边还没判断是真币的硬币重量+1,左边硬币-1;
        {
        for(j=0;j<len;j++)
        {
        x=s1[j]-'A';
        if(a[x]!=10)
        a[x]=a[x]-1;
        y=s2[j]-'A';
        if(a[y]!=10)
        a[y]=a[y]+1;
        }
        }
        }
        max=0;
        z=0;
        for(i=0;i<12;i++)//当硬币是真币时重量为10,所以可以排除重量为10的硬币为假币。假币的重量可能大于0,也可能小于0,
                        //但是被怀疑次数最多的那个就是假币,所以找出重量不等于10而且重量的绝对值最大的硬币就是假币
        {
        if(a[i]==10)
         continue;
        if(abs(a[i])>max)                 //abs函数用来求数的绝对值
        {
        max=abs(a[i]);
        z=i;
        }
        }
        if(a[z]<=0)              //当重量小于0时说明假币的重量偏轻,大于0时说明重量偏重,等于0时便无所谓了
        printf("%c is the counterfeit coin and it is light.\n",z+'A');
        else if(a[z]>0)
        printf("%c is the counterfeit coin and it is heavy.\n",z+'A');
    }
    return 0;
}
       
       
 

  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值