杭电ACM 1398 Square Coins(母函数)

                                      Square Coins

Problem Description
People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.
 
Input
The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.
 
Output
For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.
 
Sample Input
  
  
2 10 30 0
 
Sample Output
  
  
1 4 27
题目大意:有多种硬币,而且每种硬币的面值都是平方数(最大是17^2=289),给出一个数,请输出用这些硬币组成这个数有多少种方案
解题思想:在母函数模板的基础上改两处赋值的地方就行了。
 

AC代码:

#include<stdio.h>
#include<string.h>
#include<stdlib.h>
int main()
{
 int c1[400],c2[400],i,j,k,n;
 while(scanf("%d",&n)&&(n!=0))
 {
  for(i=0;i<=n;i++)              //给第一个表达式初始化
  {
   c1[i]=1;    
   c2[i]=0;
  }
  for(i=2;i*i<=n;i++)            //因为硬币都是数的平方,所以判断条件是i*i<=n
  {
   for(j=0;j<=n;j++)
   {
    for(k=0;k+j<=n;k=k+i*i)         //注意k值的变化,k=k+i*i;因为硬币只有平方数,所以每次都要加平方数
    {
     c2[k+j]=c2[k+j]+c1[j];
    }
   }
   for(j=0;j<=n;j++)
   {
    c1[j]=c2[j];
    c2[j]=0;
   }
  }
  printf("%d\n",c1[n]);
 }
 return 0;
}

解题体会:母函数还是不理解,刚开始知道赋值的时候要修改但是还是不知道该修改哪里、改成什么

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值