Square Coins (HDU-1398)(母函数)

People in Silverland use square coins. Not only they have square shapes but also their values are square numbers. Coins with values of all square numbers up to 289 (=17^2), i.e., 1-credit coins, 4-credit coins, 9-credit coins, ..., and 289-credit coins, are available in Silverland.
There are four combinations of coins to pay ten credits:

ten 1-credit coins,
one 4-credit coin and six 1-credit coins,
two 4-credit coins and two 1-credit coins, and
one 9-credit coin and one 1-credit coin.

Your mission is to count the number of ways to pay a given amount using coins of Silverland.

Input

The input consists of lines each containing an integer meaning an amount to be paid, followed by a line containing a zero. You may assume that all the amounts are positive and less than 300.

Output

For each of the given amount, one line containing a single integer representing the number of combinations of coins should be output. No other characters should appear in the output.

Sample Input

2
10
30
0

Sample Output

1
4
27

题意: 硬币种类有1^2,2^2,3^2,4^2...17^2,这几种;输入n;求出能够组合成n的组合有多少种。

思路:这道题的话,我们用母函数来求,套一下模板即可。

AC代码1:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
int sup[maxx],temp[maxx];
int main()
{
    int n;
    while(~scanf("%d",&n),n)
    {
        for(int i=0; i<=n; i++)
        {
            sup[i]=1;
            temp[i]=0;
        }
        for(int i=2; i<=n; i++)
        {
            for(int j=0; j<=n; j++)
            {
                for(int k=0; j+k<=n; k+=i*i)
                {
                    temp[j+k]+=sup[j];
                }
            }
            for(int j=0; j<=n; j++)
            {
                sup[j]=temp[j];
                temp[j]=0;
            }
        }
        printf("%d\n",sup[n]);
    }
    return 0;
}

AC代码2:

#include <bits/stdc++.h>
typedef long long ll;
const int maxx=10010;
const int inf=0x3f3f3f3f;
using namespace std;
int a[maxx],b[maxx];
int v[maxx];
int main()
{
    int n;
    for(int i=1; i<=17; i++)
        v[i]=i*i;
    while(~scanf("%d",&n),n)
    {
        memset(a,0,sizeof(a));
        a[0]=1;
        for(int i=1; i<=17; i++)
        {
           memset(b,0,sizeof(b));
           for(int j=0;j*v[i]<=n;j++)
           {
               for(int k=0;k+j*v[i]<=n;k++)
               {
                   b[k+j*v[i]]+=a[k];
               }
           }
           memcpy(a,b,sizeof(b));
        }
        printf("%d\n",a[n]);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值