S-Trees

描述

A Strange Tree (S-tree) over the variable set Xn ={x1,x2,...,xn} is a binary tree representing a Boolean functionf:{0,1}->{0,1}. Each path of the S-tree begins at the root node and consistsof n+1 nodes. Each of the S-tree's nodes has a depth, which is the amount ofnodes between itself and the root (so the root has depth 0). The nodes withdepth less than n are called non-terminal nodes. All non-terminal nodes havetwo children: the right child and the left child. Each non-terminal node ismarked with some variable xi from the variable set Xn. All non-terminal nodeswith the same depth are marked with the same variable, and non-terminal nodeswith different depth are marked with different variables. So, there is a uniquevariable xi1 corresponding to the root, a unique variable xi2 corresponding tothe nodes with depth 1, and so on. The sequence of the variablesxi1,xi2,...,xin is called the variable ordering. The nodes having depth n arecalled terminal nodes. They have no children and are marked with either 0 or 1.Note that the variable ordering and the distribution of 0's and 1's on terminalnodes are sufficient to completely describe an S-tree. 
As stated earlier, each S-tree represents a Boolean function f. If you have anS-tree and values for the variables x1,x2,...,xn, then it is quite simple tofind out what f(x1,x2,...,xn) is: start with the root. Now repeat thefollowing: if the node you are at is labelled with a variable xi, thendepending on whether the value of the variable is 1 or 0, you go its right orleft child, respectively. Once you reach a terminal node, its label gives thevalue of the function. 

 

Figure 1: S-trees for the x1 and (x2 or x3) function


On the picture, two S-trees representing the same Boolean function,f(x1,x2,x3)= x1 and (x2 or x3), are shown. For the left tree, the variable ordering is x1,x2, x3, and for the right tree it is x3, x1, x2. 

The values of the variables x1,x2,...,xn, are given as a Variable ValuesAssignment (VVA) 

(x1 = b1, x2 = b2, ..., xn = bn)


with b1,b2,...,bn in {0,1}. For instance, ( x1 = 1, x2 = 1 x3 = 0) would be avalid VVA for n = 3, resulting for the sample function above in the valuef(1,1,0) = 1 and (1 or 0) = 1. The corresponding paths are shown bold in thepicture. 

Your task is to write a program which takes an S-tree and some VVAs andcomputes f(x1,x2,...,xn) as described above.

输入

The input contains the description of several S-trees withassociated VVAs which you have to process. Each description begins with a linecontaining a single integer n, 1 <= n <= 7, the depth of the S-tree. Thisis followed by a line describing the variable ordering of the S-tree. Theformat of that line is xi1 xi2 ...xin. (There will be exactly n differentspace-separated strings). So, for n = 3 and the variable ordering x3, x1, x2,this line would look as follows: 
x3 x1 x2 

In the next line the distribution of 0's and 1's over the terminal nodes isgiven. There will be exactly 2^n characters (each of which can be 0 or 1),followed by the new-line character. The characters are given in the order inwhich they appear in the S-tree, the first character corresponds to theleftmost terminal node of the S-tree, the last one to its rightmost terminalnode. 

The next line contains a single integer m, the number of VVAs, followed by mlines describing them. Each of the m lines contains exactly n characters (eachof which can be 0 or 1), followed by a new-line character. Regardless of thevariable ordering of the S-tree, the first character always describes the valueof x1, the second character describes the value of x2, and so on. So, theline 

110 

corresponds to the VVA ( x1 = 1, x2 = 1, x3 = 0). 

The input is terminated by a test case starting with n = 0. This test caseshould not be processed.

输出

For each S-tree, output the line "S-Tree #j:",where j is the number of the S-tree. Then print a line that contains the valueof f(x1,x2,...,xn) for each of the given m VVAs, where f is the functiondefined by the S-tree. 

Output a blank line after each test case.

样例输入

 

3
x1 x2 x3
00000111
4
000
010
111
110
3
x3 x1 x2
00010011
4
000
010
111
110
0

 

样例输出

 

 

S-Tree #1:
0011

S-Tree #2:
0011

思路:将Xi赋值之后找到对应的树叶的值,最后输出。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
#define inf 0x3f3f3f3f
int main()
{
    int n,k=1;
    char x[10][2],s[1050],st[10],ans[100005];
    while(~scanf("%d",&n)&&n)
    {
        for(int i=0;i<n;i++)
            scanf("%s",x[i]);
        scanf("%s",s+(int)pow(2,n));
        int t,tt=0;
        scanf("%d",&t);
        while(t--)
        {
            scanf("%s",st);
            int a=1;
            for(int i=0;i<n;i++)
            {
                if(st[x[i][1]-'0'-1]=='0')
                    a*=2;
                else a=a*2+1;
            }
            ans[tt++]=s[a];
        }
        ans[tt]='\0';
        printf("S-Tree #%d:\n%s\n\n",k++,ans);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值