Doing Homework again

Ignatius has just come back school from the 30th ACM/ICPC. Now he has a lot of homework to do. Every teacher gives him a deadline of handing in the homework. If Ignatius hands in the homework after the deadline, the teacher will reduce his score of the final test. And now we assume that doing everyone homework always takes one day. So Ignatius wants you to help him to arrange the order of doing homework to minimize the reduced score.

Input

The input contains several test cases. The first line of the input is a single integer T that is the number of test cases. T test cases follow. 
Each test case start with a positive integer N(1<=N<=1000) which indicate the number of homework.. Then 2 lines follow. The first line contains N integers that indicate the deadlines of the subjects, and the next line contains N integers that indicate the reduced scores. 

Output

For each test case, you should output the smallest total reduced score, one line per test case. 

Sample Input

3
3
3 3 3
10 5 1
3
1 3 1
6 2 3
7
1 4 6 4 2 4 3
3 2 1 7 6 5 4

Sample Output

0
3
5

思路:首先将作业失去的分数从大到小排序,先写失分最大的作业,在截止日期写,如果这一天写其他作业,这个作业往前推,到第一天还不能写,这个作业就会失分。求失去的分数和。

#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct lou
{
    int day,fen;
}s[1010];
bool cmp(lou a,lou b)
{
    return a.fen>b.fen;
}
int book[10000];
int main()
{
    int n,t;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d",&n);
        int i;
        for(i=0;i<n;i++)
            scanf("%d",&s[i].day);
        for(i=0;i<n;i++)
            scanf("%d",&s[i].fen);
        sort(s,s+n,cmp);//结构体排序;
        memset(book,0,sizeof(book));
        int sum=0;
        for(i=0;i<n;i++)
        {
            int a=s[i].day;
            while(a)
            {
                if(book[a]==0)//这一天还没写作业;
                {
                    book[a]=1;//标记这一天写了作业;
                    break;
                }
                a--;
            }
            if(a==0)//这门作业只能失分;
                sum+=s[i].fen;
        }
        printf("%d\n",sum);
    }
    return 0;
}

 

  • 0
    点赞
  • 4
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值