POJ 1007 DNA Sorting

DNA Sorting

Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 100175 Accepted: 40217

Description

One measure of ``unsortedness'' in a sequence is the number of pairs of entries that are out of order with respect to each other. For instance, in the letter sequence ``DAABEC'', this measure is 5, since D is greater than four letters to its right and E is greater than one letter to its right. This measure is called the number of inversions in the sequence. The sequence ``AACEDGG'' has only one inversion (E and D)---it is nearly sorted---while the sequence ``ZWQM'' has 6 inversions (it is as unsorted as can be---exactly the reverse of sorted). 

You are responsible for cataloguing a sequence of DNA strings (sequences containing only the four letters A, C, G, and T). However, you want to catalog them, not in alphabetical order, but rather in order of ``sortedness'', from ``most sorted'' to ``least sorted''. All the strings are of the same length. 

Input

The first line contains two integers: a positive integer n (0 < n <= 50) giving the length of the strings; and a positive integer m (0 < m <= 100) giving the number of strings. These are followed by m lines, each containing a string of length n.

Output

Output the list of input strings, arranged from ``most sorted'' to ``least sorted''. Since two strings can be equally sorted, then output them according to the orginal order.

Sample Input

10 6
AACATGAAGG
TTTTGGCCAA
TTTGGCCAAA
GATCAGATTT
CCCGGGGGGA
ATCGATGCAT

Sample Output

CCCGGGGGGA
AACATGAAGG
GATCAGATTT
ATCGATGCAT
TTTTGGCCAA
TTTGGCCAAA

Source

East Central North America 1998

 

#include<iostream>
#include<algorithm>
#include<string>
#include<cstdlib>
using  namespace  std;

typedef  struct
{
   string dna;
   int count;
}DNA;
DNA  dna[101];
int  cmp(const  void  *a,const  void *b)
{
  DNA  *aa=(DNA *)a;
  DNA  *bb=(DNA *)b;
  return  aa->count-bb->count;
};
int  main(void)
{
    int n,m;
    cin>>n>>m;
    for(int  i=0;i<m;i++)
    {
       cin>>dna[i].dna;
       dna[i].count=0;
       for (int j= 0; j<n;j++)
       {
          for(int k=j+1;k<n;k++)
          {
             if(dna[i].dna[j]>dna[i].dna[k])
              ++dna[i].count;
          }
       }
     }

       qsort(dna,m,sizeof(DNA),cmp);
       for(int i=0;i<m;i++)
       {
          cout<<dna[i].dna<<endl;
       }
       return 0;
}<iostream>
#include<algorithm>
#include<string>
#include<cstdlib>
using  namespace  std;

typedef  struct
{
   string dna;
   int count;
}DNA;
DNA  dna[101];
int  cmp(const  void  *a,const  void *b)
{
  DNA  *aa=(DNA *)a;
  DNA  *bb=(DNA *)b;
  return  aa->count-bb->count;
};
int  main(void)
{
    int n,m;
    cin>>n>>m;
    for(int  i=0;i<m;i++)
    {
       cin>>dna[i].dna;
       dna[i].count=0;
       for (int j= 0; j<n;j++)
       {
          for(int k=j+1;k<n;k++)
          {
             if(dna[i].dna[j]>dna[i].dna[k])
              ++dna[i].count;
          }
       }
     }

       qsort(dna,m,sizeof(DNA),cmp);
       for(int i=0;i<m;i++)
       {
          cout<<dna[i].dna<<endl;
       }
       return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值