杭电oj1002

A + B Problem II

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 418530    Accepted Submission(s): 81192


Problem Description
I have a very simple problem for you. Given two integers A and B, your job is to calculate the Sum of A + B.
 

Input
The first line of the input contains an integer T(1<=T<=20) which means the number of test cases. Then T lines follow, each line consists of two positive integers, A and B. Notice that the integers are very large, that means you should not process them by using 32-bit integer. You may assume the length of each integer will not exceed 1000.
 

Output
For each test case, you should output two lines. The first line is "Case #:", # means the number of the test case. The second line is the an equation "A + B = Sum", Sum means the result of A + B. Note there are some spaces int the equation. Output a blank line between two test cases.
 

Sample Input
 
 
2 1 2 112233445566778899 998877665544332211
 

Sample Output
 
 
Case 1: 1 + 2 = 3 Case 2: 112233445566778899 + 998877665544332211 = 1111111111111111110
 

Author
Ignatius.L
 
答案:

#include <stdio.h>
#include <stdlib.h>
#include <string.h>


void main()
{
int n;
char stra[1002],strb[1002];//字符数组
int a[1002]={0},b[1002]={0};//整型数组
scanf("%d",&n);
int i;
int lena,lenb;
int sign=0;
while(n--)
{
scanf("%s %s",&stra,&strb);
lena = strlen(stra);
lenb = strlen(strb);
for(i=1;i<=lena;i++)
{
a[i] = (int)stra[i-1] - 48;
}
for(i=1;i<=lenb;i++)
{
b[i] = (int)strb[i-1] - 48;
}
if(lena<=lenb)
{
for(i=0;i<lenb;i++)
{
if(lena-i>=1)
b[lenb-i] = b[lenb-i]+a[lena-i];
if(b[lenb-i]>=10)
{
b[lenb-i-1] = b[lenb-i-1] + b[lenb-i]/10;
b[lenb-i] = b[lenb-i]%10;
}
}
if(b[1]>=10)
{
b[0] = b[1]/10;
b[1] = b[1]%10;
}
}
else
{
for(i=0;i<lena;i++)
{
if(lenb-i>=1)
a[lena-i] = a[lena-i]+b[lenb-i];
if(a[lena-i]>=10)
{
a[lena-i-1] = a[lena-i-1] + a[lena-i]/10;
a[lena-i] = a[lena-i]%10;
}
}
if(a[1]>=10)
{
a[0] = a[1]/10;
a[1] = a[1]%10;
}
}
printf("Case %d:\n",++sign);
printf("%s + %s = ",stra,strb);
if(lena<=lenb)
{
if(b[0]!=0)
printf("%d",b[0]);
for(i=1;i<=lenb;i++)
printf("%d",b[i]);
printf("\n");
}
else
{
if(b[0]!=0)
printf("%d",a[0]);
for(i=1;i<=lena;i++)
printf("%d",a[i]);
printf("\n");
}
if(n!=0)
printf("\n");
}
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值