喷水装置(二)
时间限制:
3000 ms | 内存限制:
65535 KB
难度:
4
-
描述
-
有一块草坪,横向长w,纵向长为h,在它的橫向中心线上不同位置处装有n(n<=10000)个点状的喷水装置,每个喷水装置i喷水的效果是让以它为中心半径为Ri的圆都被润湿。请在给出的喷水装置中选择尽量少的喷水装置,把整个草坪全部润湿。
-
输入
-
第一行输入一个正整数N表示共有n次测试数据。
每一组测试数据的第一行有三个整数n,w,h,n表示共有n个喷水装置,w表示草坪的横向长度,h表示草坪的纵向长度。
随后的n行,都有两个整数xi和ri,xi表示第i个喷水装置的的横坐标(最左边为0),ri表示该喷水装置能覆盖的圆的半径。
输出
-
每组测试数据输出一个正整数,表示共需要多少个喷水装置,每个输出单独占一行。
如果不存在一种能够把整个草坪湿润的方案,请输出0。
样例输入
-
2 2 8 6 1 1 4 5 2 10 6 4 5 6 5
样例输出
-
1 2
来源
- 《算法艺术与信息学竞赛》 上传者
- 张云聪
-
第一行输入一个正整数N表示共有n次测试数据。
原题链接:http://acm.nyist.net/JudgeOnline/problem.php?pid=12
参考博客:http://blog.csdn.net/ygqwan/article/details/7884229
AC代码:
#include <iostream>
#include <algorithm>
#include <cmath>
#include <cstdio>
using namespace std;
const int maxn=10000+5;
struct Node
{
double left,right;
} a[maxn];
bool cmp(Node x,Node y)
{
return x.left<y.left;
}
int main()
{
int T,n,w,h;
ios::sync_with_stdio(false);
cin.tie(0);
cin>>T;
while(T--)
{
cin>>n>>w>>h;
double x,r;
int cnt=0;
for(int i=0; i<n; i++)
{
cin>>x>>r;
double y=sqrt(r*r-h*h/4.0);
if(y>0)
{
a[cnt].left=x-y;
a[cnt].right=x+y;
cnt++;
}
}
sort(a,a+cnt,cmp);
double maxx=0;
//左边能接上上次覆盖范围的前提下最长覆盖长度
double sum=0;//已经覆盖区间长度
int ans=0;
bool flag=true;
while(sum<w)
{
maxx=0;
for(int i=0; i<cnt&&a[i].left<=sum; i++)
{
if(a[i].right-sum>maxx)
maxx=a[i].right-sum;
}
if(maxx==0)
{
flag=false;
break;
}
else
{
ans++;
sum+=maxx;
}
}
if(flag)
cout<<ans<<endl;
else
cout<<"0"<<endl;
}
return 0;
}