HDU 3605 Escape 【二分匹配之多重匹配】

153 篇文章 0 订阅
8 篇文章 0 订阅

Escape

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 9224    Accepted Submission(s): 2156


Problem Description
2012 If this is the end of the world how to do? I do not know how. But now scientists have found that some stars, who can live, but some people do not fit to live some of the planet. Now scientists want your help, is to determine what all of people can live in these planets.
 

Input
More set of test data, the beginning of each data is n (1 <= n <= 100000), m (1 <= m <= 10) n indicate there n people on the earth, m representatives m planet, planet and people labels are from 0. Here are n lines, each line represents a suitable living conditions of people, each row has m digits, the ith digits is 1, said that a person is fit to live in the ith-planet, or is 0 for this person is not suitable for living in the ith planet.
The last line has m digits, the ith digit ai indicates the ith planet can contain ai people most..
0 <= ai <= 100000
 

Output
Determine whether all people can live up to these stars
If you can output YES, otherwise output NO.
 

Sample Input
  
  
1 1 1 1 2 2 1 0 1 0 1 1
 

Sample Output
  
  
YES NO
 

Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=3605


题意:

给出每个人适合住的星球信息和该星球能住多少人 

第一行给出n m 代表有 n 个人 m 个星球

然后接下来n行每行m个数字 1代表适合第 i 个星球 0 代表不适合第 i 个星球

最后一行m个数表示第 i 个星球最多可以住多少个人

问是不是所有人都可以住到星球上

思路:

多重匹配

Tips:

多重匹配即 X 集合上的点对应 Y 集合上多个点 而 Y 集合上的点对应 X 中的一个点


参考博客:http://www.cnblogs.com/Griselda/archive/2012/09/17/2689345.html

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=100000+5;
int n,m;
bool a[maxn][12];
bool vis[12];
int link[maxn][12];
//link[i][j]=k
//第i个星球的第j个人是k(第k个人)
int cap[12];
int cnt[12];
bool Find(int x)
{
    for(int i=0;i<m;i++)
    {
        if(!vis[i]&&a[x][i])
        {
            vis[i]=true;
            if(cnt[i]<cap[i])//人口数小于星球上限
            {
                link[i][cnt[i]++]=x;
                return true;
            }
            for(int j=0;j<cnt[i];j++)
            {
                if(Find(link[i][j]))//给link[i][j]找新的星球
                {
                    link[i][j]=x;
                    return true;
                }
            }
        }
    }
    return false;
}
bool maxMatch()
{
    memset(link,0,sizeof(link));
    memset(cnt,0,sizeof(cnt));
    int ans=0;
    for(int i=0;i<n;i++)
    {
        memset(vis,false,sizeof(vis));
        if(!Find(i))
            return false;
    }
    return true;
}
int main()
{
    while(cin>>n>>m)
    {
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<m;j++)
                scanf("%d",&a[i][j]);
        }
        for(int i=0;i<m;i++)
           scanf("%d",&cap[i]);
        if(maxMatch())
            cout<<"YES"<<endl;
        else
            cout<<"NO"<<endl;
    }
    return 0;
}


尊重原创,转载请注明出处: http://blog.csdn.net/hurmishine


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值