BestCoder Round #89 1001 & HDU 5944 Fxx and string【字符串,等比数列】

153 篇文章 0 订阅
3 篇文章 0 订阅

Fxx and string

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/65536 K (Java/Others)
Total Submission(s): 598    Accepted Submission(s): 253


Problem Description
Young theoretical computer scientist Fxx get a string which contains lowercase letters only.

The string  S  contains  n  lowercase letters  S1S2Sn .Now Fxx wants to know how many three tuple  (i,j,k)  there are which can meet the following conditions:

1、 i,j,k  are adjacent into a geometric sequence.

2、 Si= ' y ' ,Sj= ' r ' ,Sk= ' x '.

3.Either j|i or j|k
 

Input
In the first line, there is an integer  T(1T100)  indicating the number of test cases.

T  lines follow, each line contains a string, which contains only lowercase letters.(The length of string will not exceed  10000 ).
 

Output
For each case, output the answer.
 

Sample Input
  
  
2 xyyrxx yyrrxxxxx
 

Sample Output
  
  
0 2
 

Source

原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=5944

中文链接:http://bestcoder.hdu.edu.cn/contests/contest_chineseproblem.php?cid=730&pid=1001


题意:

青年理论计算机科学家Fxx得到了一个只包含小写字母的字符串。

字符串的长度为\:nn,下标从1开始,第\:i\:i位的字母为\:s_isi,现在Fxx想知道有多少三元组\:(i,j,k)\:(i,j,k)满足下列条件

1、i,j,k\:i,j,k三个数成等比数列

2、s_i=si='yy',s_j=,sj='rr',s_k=,sk='xx'

3.i/ji/jk/jk/j中必须有整数
关键就是第三个条件,一般只会想到例如1,2,4的情况,4,2,1的情况,因为4/2为整数。

思路:枚举起点和公比就OK了,起点范围[ 1 , length / 4 ]。因为公比为2(最小的情况)假如长度为10000

三个位置分别为:2500,5000,10000。

AC代码:

#include <cstdio>
#include <cstring>
#include <iostream>
using namespace std;
const int maxn=10000+5;
char a[maxn];
int main()
{
    int T;
    cin>>T;
    while(T--)
    {
        cin>>a+1;
        int len=strlen(a+1);
        int ans=0;
        for(int i=1; i<=len&&i<=len/4; i++) //枚举首项
        {
            for(int j=2; i*j*j<=len; j++) //枚举公比
            {
                if(a[i]=='y'&&a[i*j]=='r'&&a[i*j*j]=='x')
                    ans++;
                if(a[i]=='x'&&a[i*j]=='r'&&a[i*j*j]=='y')
                    ans++;
            }
        }
        cout<<ans<<endl;
    }
    return 0;
}


尊重原创,转载请注明出处:http://blog.csdn.net/hurmishine



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值