【2017多校第二场】HDU 6075 Questionnaire【思维】

Questionnaire

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 524288/524288 K (Java/Others)
Total Submission(s): 714    Accepted Submission(s): 487
Special Judge


Problem Description
In order to get better results in official ACM/ICPC contests, the team leader comes up with a questionnaire. He asked everyone in the team whether to have more training.



Picture from Wikimedia Commons


Obviously many people don't want more training, so the clever leader didn't write down their words such as ''Yes'' or ''No''. Instead, he let everyone choose a positive integer  ai  to represent his opinion. When finished, the leader will choose a pair of positive interges  m(m>1)  and  k(0k<m) , and regard those people whose number is exactly  k  modulo  m  as ''Yes'', while others as ''No''. If the number of ''Yes'' is not less than ''No'', the leader can have chance to offer more training.

Please help the team leader to find such pair of  m  and  k .
 

Input
The first line of the input contains an integer  T(1T15) , denoting the number of test cases.

In each test case, there is an integer  n(3n100000)  in the first line, denoting the number of people in the ACM/ICPC team.

In the next line, there are  n  distinct integers  a1,a2,...,an(1ai109) , denoting the number that each person chosen.
 

Output
For each test case, print a single line containing two integers  m  and  k , if there are multiple solutions, print any of them.
 

Sample Input
  
  
1 6 23 3 18 8 13 9
 

Sample Output
  
  
5 3
 

Source


原题链接:http://acm.hdu.edu.cn/showproblem.php?pid=6075

题意:每个人选择一个正整数,队长选择两个数m,k,对于每个人选择的数,如果对m取余,结果为k,则得到一个‘yes’,否则得到‘No’,如果最后‘Yes’的数量大于等于‘No’,则队长将得到更多的训练机会

问,队长如何选择m,k

一个数对m取余,结果为[0,m-1],所以我们取m=2,判断奇偶即可。

AC代码:

/**
  * 行有余力,则来刷题!
  * 博客链接:http://blog.csdn.net/hurmishine
  * 个人博客网站:http://wuyunfeng.cn/
*/
#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;
const int maxn=800000+5;
char a[maxn],b[maxn];
int main()
{
    int T;
    cin>>T;
    int n,x,y;
    while(T--)
    {
        scanf("%d%d%d",&n,&x,&y);
        scanf("%s",a);
        scanf("%s",b);
        int cnt=0;
        for(int i=0;i<n;i++)
        {
            if(a[i]!=b[i])
                cnt++;
        }
        if(abs(x-y)<=cnt&&x+y<=2*n-cnt)
            printf("Not lying\n");
        else
            printf("Lying\n");
    }
    return 0;
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值