linux包依赖问题解决

昨天晚上准备装subversion 结果碰到一个很恼火的问题

 

[root@rhel6beta Packages]# rpm -ivh libproxy-0.3.0-1.el6.i686.rpm
warning: libproxy-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy-bin = 0.3.0-1.el6 is needed by libproxy-0.3.0-1.el6.i686
        libproxy-python = 0.3.0-1.el6 is needed by libproxy-0.3.0-1.el6.i686
[root@rhel6beta Packages]# rpm -ivh libproxy-bin-0.3.0-1.el6.i686.rpm
warning: libproxy-bin-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy = 0.3.0-1.el6 is needed by libproxy-bin-0.3.0-1.el6.i686
        libproxy.so.0 is needed by libproxy-bin-0.3.0-1.el6.i686
[root@rhel6beta Packages]# rpm -ivh libproxy-python-0.3.0-1.el6.i686.rpm
warning: libproxy-python-0.3.0-1.el6.i686.rpm: Header V3 RSA/SHA256 Signature, key ID f21541eb: NOKEY
error: Failed dependencies:
        libproxy = 0.3.0-1.el6 is needed by libproxy-python-0.3.0-1.el6.i686

 

三个包互相依赖...

 

在网上找了好久,最终发现了一个解决办法

就是 rpm -ivh libproxy-0.3.0-1.el6.i686.rpm libproxy-bin-0.3.0-1.el6.i686.rpm libproxy-python-0.3.0-1.el6.i686.rpm

将三个包同时放在一起安装 问题解决

 

以此注记

Linux常见问题解决

06-13

本人也是一名linux新手,此贴转为新手而发,大牛们见笑了。rn微软我对不起你,我从刚接触计算机起用的盗版的win98,后来用盗版XP,最后用盗版win7,现在我更对不起你,我抛弃你啦!rnrn  现在装上了Ubuntu/Linux彻底抛弃了windows,用了Ubuntu两个月了,从开始到现在遇到了不少问题,一个一个解决,到现在终于可以想使用windows一样随心所欲的使用Linux了。rnrn  最近貌似网上Linux很火似的,好所朋友也问我Linux的一些问题,linux毕竟用户较少,所以好多问题还要我们自己解决,才能正常的使用Linux。rnrn(这里均已Ubuntu为例)rnrn  简单问题:rnrn    1.中文输入发:rnrn    Ubuntu10.04一下用户可以下载scim输入法或fcitx输入法。个人强烈推荐scim输入法,安装scim输入法的方法:sudo apt-get remove scim(首先卸载原来的输入平台这个SCIM只是一个空壳子而已),sudo apt-get install scim scim-chinese(然后安装scim和scim-chinese这里边就包含了拼音输入法喜欢五笔的拼音可以安装scim-table) 最后再sudo im-switch -s scim -z default(把scim设为默认输入法)。rnrn    对于Ubuntu10.04进去之后我们可以右键单击右上角的一个键盘的图标,选择首选项,选择输入法设置,选择汉语拼音然后添加,这样点几下Ibus输入就能很方便的使用了。rnrn    2.flash中文乱码rnrn        需要改变一下字体:rnrn        sudo gedit /etc/fonts/conf.d/49-sansserif.conf rnrn        然后改变最后一段中的sans-serif这个字符串,改为scan保存退出即可。rnrn    3.网络连接问题rnrn    如果你是用的是拨号连接那么请输入:rnrn    sudo pppoeconf 进入拨号连接设置,系统会让你输入连接账号和密码这样就能连接了。rnrn    如果你是内网用户,一般情况下直接自动就连接好了,如果无法连接了就输入命令:rnrn    sudo dhclient 这样会自动寻找连接的路由器并且自动设置IP和网管rnrn    4.无法切换到root账户下,大多数Ubuntu装好后su - root时需要输入密码,而这个密码一般应该是默认的rootrnrn但是事实上看来我们并不是这个,也不是我们普通账户的密码,这时可以使用 sudo passwd root 首先输入当前用户的密码,然后输入root用户的新密码,这样就可以切换到root权限下。rnrn    5.开发JAVA的用户往往无法使用Eclispe,提示环境变量错误,这里介绍两种办法:rnrn       1.sudo apt-get install eclipse直接下载eclipse安装eclispe的同时就把JDK安装了。并且不用设置PATHrnrn       2.如果你安装了Eclispe还提示PATH的问题,那么你首先安装openjdk ,                      sudo apt-get install openjdk-sun-jdk 这样也也不会牵扯到PATH的问题。rnrn        顺便说一下:eclispe的意思是“月食”,现在下载的Eclipse的版本是Eclipse Galileo,Galileo就是那个两个铁球同时落地的老爷爷,传说装这个代号的辟邪。rnrn 最后再说一下,本人也是新手,解决这些问题也费了还多精力,贴出来希望大家少走弯路,我的QQ763170916,共勉!rn

请教perl-DBD-mysql-4.012-1.el5.rf.i386 包依赖问题!

09-03

请教perl-DBD-mysql-4.012-1.el5.rf.i386 包依赖问题!rnrn[root@ThinkPad /]# yum update rn载入插件: rn设置更新进程rn解决依赖相关rnThere are unfinished transactions remaining. You might consider running yum-complete-transaction first to finish them.rnSkipping security plugin, no datarn-->运行处理检查rn---> 包 alsa-lib.i586 0:1.0.21-1.fc11 设置为 升级 rn---> 包 alsa-lib-devel.i586 0:1.0.21-1.fc11 设置为 升级 rn---> 包 ctags.i586 0:5.8-1.fc11 设置为 升级 rn---> 包 dcraw.i586 0:8.96-1.fc11 设置为 升级 rn---> 包 doxygen.i586 1:1.6.1-1.fc11 设置为 升级 rn---> 包 gimp.i586 2:2.6.7-2.fc11 设置为 升级 rn---> 包 gimp-help-browser.i586 2:2.6.7-2.fc11 设置为 升级 rn---> 包 gimp-libs.i586 2:2.6.7-2.fc11 设置为 升级 rn---> 包 imsettings.i586 0:0.107.3-1.fc11 设置为 升级 rn---> 包 imsettings-libs.i586 0:0.107.3-1.fc11 设置为 升级 rn---> 包 imsettings-xfce.i586 0:0.107.3-1.fc11 设置为 升级 rn---> 包 perl-DBD-Pg.i386 0:2.14.1-1.el5.rf 设置为 升级 rn--> 过程依赖: libpq.so.4 依赖于包: perl-DBD-Pg-2.14.1-1.el5.rf.i386rn---> 包 perl-DBD-mysql.i386 0:4.012-1.el5.rf 设置为 升级 rn--> 过程依赖: libmysqlclient.so.15(libmysqlclient_15) 依赖于包: perl-DBD-mysql-4.012-1.el5.rf.i386rn--> 过程依赖: libssl.so.6 依赖于包: perl-DBD-mysql-4.012-1.el5.rf.i386rn--> 过程依赖: libmysqlclient.so.15 依赖于包: perl-DBD-mysql-4.012-1.el5.rf.i386rn--> 过程依赖: libcrypto.so.6 依赖于包: perl-DBD-mysql-4.012-1.el5.rf.i386rn---> 包 qt.i586 1:4.5.2-3.fc11 设置为 升级 rn---> 包 qt-devel.i586 1:4.5.2-3.fc11 设置为 升级 rn---> 包 qt-mysql.i586 1:4.5.2-3.fc11 设置为 升级 rn---> 包 qt-x11.i586 1:4.5.2-3.fc11 设置为 升级 rn---> 包 readahead.i586 1:1.5.0-1.fc11 设置为 升级 rn---> 包 redhat-rpm-config.noarch 0:9.0.3-11.fc11 设置为 升级 rn--> 过程依赖: subversion = 1.6.4-2.fc11 依赖于包: subversion-javahl-1.6.4-2.fc11.i586rn---> 包 subversion.i386 0:1.6.5-0.1.el5.rf 设置为 升级 rn--> 过程依赖: libssl.so.6 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 过程依赖: libdb-4.3.so 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 过程依赖: liblber-2.3.so.0 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 过程依赖: libneon.so.25 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 过程依赖: libldap-2.3.so.0 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 过程依赖: libcrypto.so.6 依赖于包: subversion-1.6.5-0.1.el5.rf.i386rn--> 完成依赖性检查rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libdb-4.3.so 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rnperl-DBD-Pg-2.14.1-1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libpq.so.4 被包 perl-DBD-Pg-2.14.1-1.el5.rf.i386 (rpmforge) 所需要rnsubversion-javahl-1.6.4-2.fc11.i586 已从installed 解决了问题rn --> 丢失的依赖相关: subversion = 1.6.4-2.fc11 被包 subversion-javahl-1.6.4-2.fc11.i586 (installed) 所需要rnperl-DBD-mysql-4.012-1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libmysqlclient.so.15 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rnperl-DBD-mysql-4.012-1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libssl.so.6 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libneon.so.25 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libcrypto.so.6 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rnperl-DBD-mysql-4.012-1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libmysqlclient.so.15(libmysqlclient_15) 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rnperl-DBD-mysql-4.012-1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libcrypto.so.6 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: liblber-2.3.so.0 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libssl.so.6 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rnsubversion-1.6.5-0.1.el5.rf.i386 已从rpmforge 解决了问题rn --> 丢失的依赖相关: libldap-2.3.so.0 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libcrypto.so.6 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libssl.so.6 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libpq.so.4 被包 perl-DBD-Pg-2.14.1-1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libldap-2.3.so.0 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libmysqlclient.so.15(libmysqlclient_15) 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libssl.so.6 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libmysqlclient.so.15 被包 perl-DBD-mysql-4.012-1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libcrypto.so.6 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: liblber-2.3.so.0 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: subversion = 1.6.4-2.fc11 被包 subversion-javahl-1.6.4-2.fc11.i586 (installed) 所需要rn错误: 丢失的依赖相关: libdb-4.3.so 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn错误: 丢失的依赖相关: libneon.so.25 被包 subversion-1.6.5-0.1.el5.rf.i386 (rpmforge) 所需要rn You could try using --skip-broken to work around the problemrn You could try running: package-cleanup --problemsrn package-cleanuprnrn[root@ThinkPad /]# uname -arnLinux ThinkPad 2.6.29.6-217.2.16.fc11.i586 #1 SMP Mon Aug 24 17:01:46 EDT 2009 i686 i686 i386 GNU/Linuxrn[root@ThinkPad /]# rnrnrn[root@ThinkPad /]# rpm -qa | grep mysqlrnmysqlclient16-devel-5.1.30-1.el5.remi.i386rnsoci-mysql-3.0.0-13.fc11.i586rnmysql-libs-5.1.36-1.fc11.i586rnlibmysqlpp3-3.0.8-1mdv2009.1.i586rnmysql-server-5.1.36-1.fc11.i586rnlibgda-mysql-devel-4.0.2-1.fc11.i586rnmysql-embedded-5.1.36-1.fc11.i586rnocaml-mysql-1.0.4-8.fc11.i586rnqt-mysql-4.5.2-2.fc11.i586rnlibdbi-dbd-mysql-0.8.3-4.fc11.i586rnmysql-5.1.36-1.fc11.i586rnphp-mysql-5.2.9-2.fc11.i586rnocaml-mysql-devel-1.0.4-8.fc11.i586rnmysql-connector-java-3.1.12-7.fc11.i586rnlibgda-mysql-4.0.2-1.fc11.i586rnmysql-connector-odbc-5.1.5r1144-4.fc11.i586rnmysql-devel-5.1.36-1.fc11.i586rnperl-DBD-mysql-debuginfo-4.012-2.i686rnsoci-mysql-devel-3.0.0-13.fc11.i586rn[root@ThinkPad /]# rnrnrn

没有更多推荐了,返回首页

私密
私密原因:
请选择设置私密原因
  • 广告
  • 抄袭
  • 版权
  • 政治
  • 色情
  • 无意义
  • 其他
其他原因:
120
出错啦
系统繁忙,请稍后再试