UVA 10391 Compound Words

http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=19793
You are to nd all the two-word compound words in a dictionary. A two-word compound word is a
word in the dictionary that is the concatenation of exactly two other words in the dictionary.
Input
Standard input consists of a number of lowercase words, one per line, in alphabetical order. There will
be no more than 120,000 words.
Output
Your output should contain all the compound words, one per line, in alphabetical order.
Sample Input
a
alien
born
less
lien
never
nevertheless
new
newborn
the
zebra
Sample Output
alien
newborn

题意:
给定一个词典,要求找出其中所有的复合词,即恰好由两个单词连接而成的词

题解
可以用hash,trie
当然也可以用stl的set!
尽情享受stl中set和string强强联手之下的超优美程序吧

#include<iostream>
#include<set>
using namespace std;

int main() {
    set<string> s;
    string tmp;
    while (cin >> tmp)
        s.insert(tmp);
    set<string>::iterator it=s.begin();
    for (it; it!=s.end(); it++)
    {
        tmp=*it;
        for (int i=0; i<tmp.length(); i++)
            if (s.count(tmp.substr(0, i)) && s.count(tmp.substr(i, tmp.length()-i))){
                cout<<tmp<<endl;
                break;
            }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值