ZCMU1779

1779: 无法言表

Time Limit: 1 Sec   Memory Limit: 128 MB
Submit: 230   Solved: 88
[ Submit][ Status][ Web Board]

Description

给出N个数,要求把其中的重复的去掉,只保留第一次出现的数.1 <= N <= 50000,给出的数在32位有符号整数范围内。

Input

第一行T(T<=10),接下来一个数n,接下来n个数

Output

Case #x: y1,y2,...,x是测试编号从1开始,y_i表示答案

Sample Input

2111 2 18 3 3 19 2 3 6 5 461 2 3 4 5 6

Sample Output

Case #1: 1 2 18 3 19 6 5 4Case #2: 1 2 3 4 5 6

HINT

Source


去重问题,用map
#include<cstdio>
#include<iostream>
#include<map>
#include<algorithm>
#include<string>
using namespace std;
map<int,int> mapa;
int main()
{
    int t,n,i,x;
    int y;
    scanf("%d",&t);
    x=0;
    while(t--){
    mapa.clear();
    scanf("%d",&n);
    x++;
    printf("Case #%d:",x);
        for(i=1;i<=n;i++){
            scanf("%d",&y);
            if(mapa[y]) continue;
            else
            {
                mapa[y]=1;
            printf(" %d",y);
            }
        }
        printf("\n");
    }
    return 0;
}


  • 0
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值