1036 Boys vs Girls (25)(25 分)

1036 Boys vs Girls (25)(25 分)
This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

Input Specification:

Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

Output Specification:

For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade~F~-grade~M~. If one such kind of student is missing, output “Absent” in the corresponding line, and output “NA” in the third line instead.

Sample Input 1:

3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

Sample Output 1:

Mary EE990830
Joe Math990112
6

Sample Input 2:

1
Jean M AA980920 60
Sample Output 2:
Absent
Jean AA980920
NA

题目大意:给出n个同学的信息,输出女生中最高分获得者的信息和男生中最低分获得者的信息,并输出他们的差。如果不存在男生或女生在对应位置输出Absent,在分数差的位置输出NA

#include<cstdio>
struct person {
    char name[15];
    char id[15];
    int score;
}male, female, temp;
void init() {
    male.score = 101;
    female.score = -1;
}
int main() {
    init();
    int n;
    char gender;
    scanf("%d", &n);
    for(int i = 0; i < n; i++) {
        scanf("%s %c %s %d", temp.name, &gender, &temp.id, &temp.score);
        if(gender == 'M' && temp.score < male.score) {
            male = temp;
        } else if(gender == 'F' && temp.score > female.score) {
            female = temp;
        }
    }
    if(female.score == -1) {
        printf("Absent\n");
    } else {
        printf("%s %s\n", female.name, female.id);
    }
    if(male.score == 101) {
        printf("Absent\n");
    } else {
        printf("%s %s\n", male.name, male.id);
    }
    if(female.score == -1 || male.score == 101) {
        printf("NA\n");
    } else {
        printf("%d\n", female.score - male.score);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值