hdu acm 1532 Drainage Ditches

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 13573    Accepted Submission(s): 6410


Problem Description
Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch.
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network.
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle.
 

Input
The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.
 

Output
For each case, output a single integer, the maximum rate at which water may emptied from the pond.
 

Sample Input
  
  
5 4 1 2 40 1 4 20 2 4 20 2 3 30 3 4 10
 

Sample Output
  
  
50
 网络流——dinic算法,为何用邻接表tle,真他妈奇怪。。。。
题意:给定点数,边数,源点,汇点,求最大流。
Dinic 算法的基本步骤为:
1) 计算残余网络的层次图。我们定义 h[i] 为顶点 i 距离源 S 所经过到最小边数,求出所有顶点的 h 值,h[] 值相同的顶点属于同一层,这就是网络的层次图。
2) 在层次图上进行 BFS 增广,直到不存在增广路径。这时求得的增广路径上顶点是分层的,路径上不可能存在两个顶点属于同一层,即 h[i]== h[j] (i!= j )。同时,求得层次图后,我们可以在层次图上进行多次增广。
3) 重复 1 和 2。直到不存在增广路径。
#include<iostream>
#include<stdio.h>
#include<queue>
#include<string.h>
#include<algorithm>
#define INF 0x7fffffff
#define MS(a,b) memset(a,b,sizeof(a))
using namespace std;
int mat[505][505],d[505];
int n,m,s;
bool bfs()
{
    int i;
    queue<int>q;
    MS(d,-1);
    d[s]=1;
    q.push(s);
    while(!q.empty())
    {
        int v=q.front();
        q.pop();
      for(i=1;i<=n;i++)
      {
          if(d[i]==-1&&mat[v][i])
          {
              d[i]=d[v]+1;
              q.push(i);
          }
      }
    }
    return d[n]!=-1;
}
int dfs(int v,int cur_flow)
{
    int dt=cur_flow,i;
    if(v==n)return cur_flow;
    for(i=1;i<=n;i++)
    {
        if(mat[v][i]>0&&d[v]+1==d[i])
        {
            int flow=dfs(i,min(dt,mat[v][i]));
            mat[v][i]-=flow;
            mat[i][v]+=flow;
            dt-=flow;
        }
    }
    return cur_flow-dt;
}
int dinic()
{
    int cur_flow,ans=0;
    while(bfs())
    {
      while(cur_flow=dfs(s,INF))
        ans+=cur_flow;
    }
    return ans;
}
int main()
{
  int i,u,v,w;
  while(~scanf("%d %d",&m,&n))
  {
  MS(mat,0);
  s=1;
  for(i=0;i<m;i++)
  {
      scanf("%d %d %d",&u,&v,&w);
      if(u==v)continue;
      mat[u][v]+=w;
  }
  printf("%d\n",dinic());
  }
  return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值