POJ-1273 Drainage Ditches(最大流)

Drainage Ditches
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 71209 Accepted: 27705

Description

Every time it rains on Farmer John's fields, a pond forms over Bessie's favorite clover patch. This means that the clover is covered by water for awhile and takes quite a long time to regrow. Thus, Farmer John has built a set of drainage ditches so that Bessie's clover patch is never covered in water. Instead, the water is drained to a nearby stream. Being an ace engineer, Farmer John has also installed regulators at the beginning of each ditch, so he can control at what rate water flows into that ditch. 
Farmer John knows not only how many gallons of water each ditch can transport per minute but also the exact layout of the ditches, which feed out of the pond and into each other and stream in a potentially complex network. 
Given all this information, determine the maximum rate at which water can be transported out of the pond and into the stream. For any given ditch, water flows in only one direction, but there might be a way that water can flow in a circle. 

Input

The input includes several cases. For each case, the first line contains two space-separated integers, N (0 <= N <= 200) and M (2 <= M <= 200). N is the number of ditches that Farmer John has dug. M is the number of intersections points for those ditches. Intersection 1 is the pond. Intersection point M is the stream. Each of the following N lines contains three integers, Si, Ei, and Ci. Si and Ei (1 <= Si, Ei <= M) designate the intersections between which this ditch flows. Water will flow through this ditch from Si to Ei. Ci (0 <= Ci <= 10,000,000) is the maximum rate at which water will flow through the ditch.

Output

For each case, output a single integer, the maximum rate at which water may emptied from the pond.

Sample Input

5 4
1 2 40
1 4 20
2 4 20
2 3 30
3 4 10

Sample Output

50
网络流模板题,拆点构图什么的都不需要,直接上模板就行

#include<cstdio>
#include<algorithm>
#include<string.h>
#include<queue>
using namespace std;
const int inf = 0x3f3f3f3f;
const int maxn = 205;
const int maxe = 4 * maxn * maxn;
struct MaxFlow {
    struct Edge {
        int v, w, nxt;
    } edge[maxe];
    int head[maxn], tot, level[maxn];
    void init(){
        memset(head,-1,sizeof(head));
        tot=0;
    }
    void add(int u, int v, int w) {
        edge[tot].v = v;
        edge[tot].w = w;
        edge[tot].nxt = head[u];
        head[u] = tot++;

        edge[tot].v = u;
        edge[tot].w = 0;
        edge[tot].nxt = head[v];
        head[v] = tot++;
    }
    bool bfs(int s, int t) {
        memset(level, -1, sizeof(level));
        queue<int>q;
        q.push(s);
        level[s] = 0;
        while(!q.empty()) {
            int u = q.front(); q.pop();
            for(int i = head[u]; ~i; i = edge[i].nxt) {
                if(edge[i].w > 0 && level[edge[i].v] < 0) {
                    level[edge[i].v] = level[u] + 1;
                    q.push(edge[i].v);
                }
            }
        }
        return level[t] > 0;
    }
    int dfs(int u, int t, int f) {
        if(u == t) return f;
        for(int i = head[u]; ~i; i = edge[i].nxt) {
            int v = edge[i].v;
            if(edge[i].w > 0 && level[v] > level[u]) {
                int d = dfs(v, t, min(f, edge[i].w));
                if(d > 0) {
                    edge[i].w -= d;
                    edge[i ^ 1].w += d;
                    return d;
                }
            }
        }
        level[u] = -1; //不太确定,如果WA了把这句删掉试试
        return 0;
    }
    int solve(int s, int t) {
        int flow = 0, f;
        while(bfs(s, t)) {
            while(f = dfs(s, t, inf)) flow += f;
        }
        return flow;
    }
}F;

int main(){
   // freopen("in.txt","r",stdin);
    int n,m;
    while(~scanf("%d%d",&m,&n)){
        F.init();
        for(int i=0;i<m;i++){
            int u,v,c;
            scanf("%d%d%d",&u,&v,&c);
            F.add(u,v,c);
        }
        printf("%d\n",F.solve(1,n));
    }
    return 0;
}


  • 1
    点赞
  • 3
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值