(ACM)Elevator

Problem Description

The highest building in our city has only one elevator. A request list is made up with N positive numbers. The numbers denote at which floors the elevator will stop, in specified order. It costs 6 seconds to move the elevator up one floor, and 4 seconds to move down one floor. The elevator will stay for 5 seconds at each stop.

For a given request list, you are to compute the total time spent to fulfill the requests on the list. The elevator is on the 0th floor at the beginning and does not have to return to the ground floor when the requests are fulfilled.

Input

There are multiple test cases. Each case contains a positive integer N, followed by N positive numbers. All the numbers in the input are less than 100. A test case with N = 0 denotes the end of input. This test case is not to be processed.

Output

Print the total time on a single line for each test case.

Sample Input

1 2
3 2 3 1
0

Sample Output

17
41

Author

ZHENG, Jianqiang

## 题意 ##
题目要求我们一次输入电梯需要到达楼层,最后统计总的时间。
## 我 的代码 ##

#include <stdio.h>
int main()
{
    int data[101];
    data[0]=0;
    int i,j,n,s1,s2,s,m;
    while(scanf("%d",&n)!=EOF)
    {
        s=0;
        if(n>0&&n<=100) 
        {
            for(i=1;i<=n;i++)
            {
                scanf("%d",&data[i]);
            }
            for(i=0;i<n;i++)
            {
                if(data[i+1]>data[i])
                {
                    m=data[i+1]-data[i];
                    s1=6*m;
                    s2=5*(m-1);
                }
                else
                {
                    m=data[i]-data[i+1];
                    s1=4*m;
                    s2=5*m;
                }
                s=s1+s2+s;
            }
            printf("s=%d\n",s);
        }
        else
        {
            return 0;
        }
    }
    return 0;
}

ta

#include <stdio.h>
#include <string.h>
int main()
{
    int a[110];
    int i,n,m,sum;
    memset(a,0,sizeof(0));
    while(scanf("%d",&n)&&n)
    {
       sum=0;
       for(i=1;i<=n;i++)
           scanf("%d",&a[i]);
       for(i=1;i<=n;i++) 
       {
          if(a[i]-a[i-1]>0)
          {
            sum+=6*(a[i]-a[i-1])+5;
          }
          else  
          {
             sum+=4*(a[i-1]-a[i])+5;
          }
       } 
       printf("%d\n",sum);
    }
    return 0;
}

心得

自己编写的代码和他人的对比中,发现在计算时间时,我考虑的是每上升(下降)一层都要停留5秒钟,而题目真正意思是每到达一个指定楼层时才会停留5秒钟。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值