杭电1072 Nightmare

Problem Description

Ignatius had a nightmare last night. He found himself in a labyrinth with a time bomb on him. The labyrinth has an exit, Ignatius should get out of the labyrinth before the bomb explodes. The initial exploding time of the bomb is set to 6 minutes. To prevent the bomb from exploding by shake, Ignatius had to move slowly, that is to move from one area to the nearest area(that is, if Ignatius stands on (x,y) now, he could only on (x+1,y), (x-1,y), (x,y+1), or (x,y-1) in the next minute) takes him 1 minute. Some area in the labyrinth contains a Bomb-Reset-Equipment. They could reset the exploding time to 6 minutes.

Given the layout of the labyrinth and Ignatius' start position, please tell Ignatius whether he could get out of the labyrinth, if he could, output the minimum time that he has to use to find the exit of the labyrinth, else output -1.

Here are some rules:
1. We can assume the labyrinth is a 2 array.
2. Each minute, Ignatius could only get to one of the nearest area, and he should not walk out of the border, of course he could not walk on a wall, too.
3. If Ignatius get to the exit when the exploding time turns to 0, he can't get out of the labyrinth.
4. If Ignatius get to the area which contains Bomb-Rest-Equipment when the exploding time turns to 0, he can't use the equipment to reset the bomb.
5. A Bomb-Reset-Equipment can be used as many times as you wish, if it is needed, Ignatius can get to any areas in the labyrinth as many times as you wish.
6. The time to reset the exploding time can be ignore, in other words, if Ignatius get to an area which contain Bomb-Rest-Equipment, and the exploding time is larger than 0, the exploding time would be reset to 6.
 

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case starts with two integers N and M(1<=N,Mm=8) which indicate the size of the labyrinth. Then N lines follow, each line contains M integers. The array indicates the layout of the labyrinth.
There are five integers which indicate the different type of area in the labyrinth:
0: The area is a wall, Ignatius should not walk on it.
1: The area contains nothing, Ignatius can walk on it.
2: Ignatius' start position, Ignatius starts his escape from this position.
3: The exit of the labyrinth, Ignatius' target position.
4: The area contains a Bomb-Reset-Equipment, Ignatius can delay the exploding time by walking to these areas.
 

Output
For each test case, if Ignatius can get out of the labyrinth, you should output the minimum time he needs, else you should just output -1.
 

Sample Input
  
  
3 3 3 2 1 1 1 1 0 1 1 3 4 8 2 1 1 0 1 1 1 0 1 0 4 1 1 0 4 1 1 0 0 0 0 0 0 1 1 1 1 4 1 1 1 3 5 8 1 2 1 1 1 1 1 4 1 0 0 0 1 0 0 1 1 4 1 0 1 1 0 1 1 0 0 0 0 3 0 1 1 1 4 1 1 1 1 1
 

Sample Output
  
  
4 -1 13

题目的意思是:给你一个迷宫,0代表墙,1代表路,2代表起始位置,3代表终点,4代表爆破装置。一开始,你在2的位置,求到3的最少步数。

起初,你只有6秒钟的时间,时间减到0,你没到3的位置,代表不能出去,输出-1.想要增加时间,可以引爆爆破装置,引爆之后,时间重置为6,可以引爆多个。到引爆装置的时候,时间必须大于0,不然没有时间可以引爆。

迷宫最大是8 * 8。用广度优先搜索可以简单的解决问题。

#include <iostream>  
#include <cstdio>  
#include <cstring>  
#include <queue>  
using namespace std;  
  
typedef struct  
{   
    int Etime;  
    int x, y;  
    int count;  
}Data;  
  
int n, m, sx, sy;  
int map[9][9];  
int direction[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};  
  
int bfs()                       //广度搜索  
{  
    int i;  
    int tx, ty;  
    queue<Data> Que;  
    while(!Que.empty())  
    {  
        Que.pop();  
    }  
    Data Da, temp;  
    Da.x = sx; Da.y = sy;  
    Da.Etime = 6; Da.count = 0;  
    Que.push(Da);                       //起点入队  
    while(!Que.empty())  
  {  
        temp = Que.front();  
        Que.pop();  
        if(map[temp.x][temp.y] == 3)  //到了终点  
            return temp.count;  
        if(temp.Etime == 1)           //没到终点,时间变成1,下一步之后,时间变0,无论怎么走,都没时间了,直接跳过  
            continue;             //忽略掉时间为0的,下面的引爆就不用判断时间  
        for(i = 0; i < 4; i++)        //四个方向搜索  
        {  
            tx = temp.x + direction[i][0];  
            ty = temp.y + direction[i][1];  
            if(tx < 0 || tx >= n || ty < 0 || ty >= m || map[tx][ty] == 0)  
                continue;  
      
            Da.x = tx; Da.y = ty; Da.Etime = temp.Etime - 1; Da.count = temp.count + 1;   
            if(map[tx][ty] == 4)          //引爆,重置时间  
            {  
                Da.Etime = 6;  
                map[tx][ty] = 0;  
            }  
            Que.push(Da);  
        }  
    }  
    return -1;  
}  
int main()  
{  
//  freopen("data.txt", "r", stdin);  
    int T, i, j;  
    while(scanf("%d", &T) != EOF)  
    {  
        while(T--)  
        {  
            scanf("%d%d", &n, &m);  
            for(i = 0; i < n; i++)  
                for(j = 0; j < m; j++)  
                {  
                    scanf("%d", &map[i][j]);  
                    if(map[i][j] == 2)            //找到起点  
                    {  
                        sx = i;  
                        sy = j;  
                    }  
                }  
            int ans = bfs();  
            cout << ans << endl;  
        }  
    }  
    return 0;  
}  

  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值