hdu 5791 two 多校联赛第五场

Two

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 986    Accepted Submission(s): 453


Problem Description
Alice gets two sequences A and B. A easy problem comes. How many pair of sequence A' and sequence B' are same. For example, {1,2} and {1,2} are same. {1,2,4} and {1,4,2} are not same. A' is a subsequence of A. B' is a subsequence of B. The subsequnce can be not continuous. For example, {1,1,2} has 7 subsequences {1},{1},{2},{1,1},{1,2},{1,2},{1,1,2}. The answer can be very large. Output the answer mod 1000000007.
 

Input
The input contains multiple test cases.

For each test case, the first line cantains two integers  N,M(1N,M1000) . The next line contains N integers. The next line followed M integers. All integers are between 1 and 1000.
 

Output
For each test case, output the answer mod 1000000007.
 

Sample Input
      
      
3 2 1 2 3 2 1 3 2 1 2 3 1 2
 

Sample Output
      
      
2 3
 

Author
ZSTU
 

Source
 

Recommend
wange2014   |   We have carefully selected several similar problems for you:   5792  5790  5789  5788  5787 
 



题解

等于所有圆圈相加总和

dp[i][j]表示A序列前i个数和B序列前j个数的相同子序列对有多少个。复杂度O(n^2)O(n2)

#include<stdio.h>
#include<iostream>
#include<algorithm>
#include<string.h>
const int INF=1000000007;
using namespace std;
int n,m;
int a[1005];
int b[1005];
int dp[1005][1005];
int main()
{
   while(scanf("%d%d",&n,&m)!=EOF)
   {
       for(int i=1;i<=n;i++)
        scanf("%d",&a[i]);
       for(int i=1;i<=m;i++)
        scanf("%d",&b[i]);
        memset(dp,0,sizeof(dp));
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=m;j++)
           {
               if(a[i]==b[j])
               {
                   dp[i][j]=(dp[i-1][j]+dp[i][j-1]+1)%INF;
               }
               else
               {
                   dp[i][j]=(dp[i-1][j]+dp[i][j-1]-dp[i-1][j-1])%INF;
               }
           }
       }
       for(int i=1;i<=n;i++)
       {
           for(int j=1;j<=m;j++)
            printf("%d ",dp[i][j]);
           printf("\n");
       }
      if(dp[n][m]<0)
        printf("%d\n",dp[n][m]+INF);
      else
        printf("%d\n",dp[n][m]);
   }
   return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值