HDU5753 Permutation Bo 多校联赛第三场

Permutation Bo

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 1319    Accepted Submission(s): 618
Special Judge


Problem Description
There are two sequences  h1hn  and  c1cn h1hn  is a permutation of  1n . particularly,  h0=hn+1=0 .

We define the expression  [condition]  is 1 when  condition  is True,is 0 when  condition  is False.

Define the function  f(h)=ni=1ci[hi>hi1  and  hi>hi+1]

Bo have gotten the value of  c1cn , and he wants to know the expected value of  f(h) .
 

Input
This problem has multi test cases(no more than  12 ).

For each test case, the first line contains a non-negative integer  n(1n1000) , second line contains  n  non-negative integer  ci(0ci1000) .
 

Output
For each test cases print a decimal - the expectation of  f(h) .

If the absolute error between your answer and the standard answer is no more than  104 , your solution will be accepted.
 

Sample Input
  
  
4 3 2 4 5 5 3 5 99 32 12

 

Sample Output
  
  
6.000000 52.833333
 

Statistic |  Submit |  Clarifications |  Back
题解
根据期望的线性性,我们可以分开考虑每个位置对答案的贡献。

可以发现当 ii 不在两边的时候和两端有六种大小关系,其中有两种是对答案有贡献的。

那么对答案的贡献就是 \frac{c_i}{3}3ci

在两端的话有两种大小关系,其中有一种对答案有贡献。

那么对答案的贡献就是 \frac{c_i}{2}2ci

复杂度是 O(n)O(n)

注意特判 n=1n=1 的情况。
#include<stdio.h>
#include<iostream>
int main()
{
    int n;
    int a[1005];
    while(scanf("%d",&n)!=EOF)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&a[i]);
        double ans;
        ans=(a[0]+a[n-1])*1.0/2;
        for(int i=1;i<n-1;i++)
        {
            ans=ans+a[i]*1.0/3;
        }
        printf("%lf\n",ans);
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值