hdu(1709) 母函数

The Balance

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8017    Accepted Submission(s): 3336


Problem Description
Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.
 

Input
The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.
 

Output
For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.
 

Sample Input
  
  
3 1 2 4 3 9 2 1
 

Sample Output
  
  
0 2 4 5
题意:一个天平秤,问在他的最大范围的称量范围内,有多少种质量是无法称量的。
思路 :砝码左右都可以放置,例如 1 9 可以称量8
输入 若无就输出0
若有就输出个数 以及 不能称量的质量
#include <bits/stdc++.h>
using namespace std;
int main()
{
    int n;
    int c1[10005],c2[10005];
    int a[1000],b[1000];
    while(~scanf("%d",&n))
    {
        int sum=0,ans=0;
        vector<int > x;
        for(int i=1;i<=n;i++)
        {
            scanf("%d",&a[i]);
            sum+=a[i];
        }
        fill(c1,c1+10005,0);
        fill(c2,c2+10005,0);
        for(int i=0;i<=a[1];i+=a[1])
        c1[i]=1;
        for(int i=2;i<=n;i++)
        {
            for(int j=0;j<=sum;j++)
            {
                for(int k=0;k+j<=sum&&k<=a[i];k+=a[i])
                {
                    if(j>=k)           //左右放置的情况 
                    c2[j-k]+=c1[j];
                    else
                    c2[k-j]+=c1[j];     //左右放置的情况 
                    c2[k+j]+=c1[j];
                }
            }
            for(int j=0;j<=sum;j++)
            {
                c1[j]=c2[j];
                c2[j]=0;
            }
        }
        for(int i=1;i<=sum;i++)
        {
            if(c1[i]==0)
            x.push_back(i);
        }
        if(x.size()==0) printf("0\n");
        else
        {
            printf("%d\n",x.size());
            for(int i=0;i<x.size();i++)
            {
                if(i!=x.size()-1)
                printf("%d ",x[i]);
                else
                printf("%d\n",x[i]);
            }
        }
    }
    return 0;
        
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值