【算法竞赛入门经典】树形DP 例题9-12 UVa12186

【算法竞赛入门经典】树形DP 例题9-12 UVa12186

例题UVa12186

A couple of years ago, a new world wide crisis started, leaving many people with economical problems. Some workers of a particular company are trying to ask for an increase in their salaries.
The company has a strict hierarchy, in which each employee has exactly one direct boss, with the exception of the owner of the company that has no boss. Employees that are not bosses of any other employee are called workers. The rest of the employees and the owner are called bosses.
To ask for a salary increase, a worker should file a petition to his direct boss. Of course, each boss is encouraged to try to make their subordinates happy with their current income, making the company’s profit as high as possible. However, when at least T percent of its direct subordinates have filed a petition, that boss will be pressured and have no choice but to file a petition himself to his own direct boss. Each boss files at most 1 petition to his own direct boss, regardless on how many of his subordinates filed him a petition. A boss only accounts his direct subordinates (the ones that filed him a petition and the ones that didn’t) to calculate the pressure percentage.
Note that a boss can have both workers and bosses as direct subordinates at the same time. Such a boss may receive petitions from both kinds of employees, and each direct subordinate, regardless of its kind, will be accounted as 1 when checking the pressure percentage.
When a petition file gets all the way up to the owner of the company, all salaries are increased. The workers’ union is desperately trying to make that happen, so they need to convince many workers to file a petition to their direct boss.
Given the company’s hierarchy and the parameter T, you have to find out the minimum number of workers that have to file a petition in order to make the owner receive a petition.

Input

There are several test cases. The input for each test case is given in exactly two lines. The first line contains two integers N and T (1 ≤ N ≤ 105 , 1 ≤ T ≤ 100), separated by a single space. N indicates the number of employees of the company (not counting the owner) and T is the parameter described above. Each of the employees is identified by an integer between 1 and N. The owner is identified by the number 0. The second line contains a list of integers separated by single spaces. The integer Bi, at position i on this list (starting from 1), indicates the identification of the direct boss of employee i (0 ≤ Bi ≤ i−1).
The last test case is followed by a line containing two zeros separated by a single space.

Output

For each test case output a single line containing a single integer with the minimum number of workers that need to file a petition in order to get the owner of the company to receive a petition.

Sample Input

3 100
0 0 0
3 50
0 0 0
14 60
0 0 1 1 2 2 2 5 7 5 7 5 7 5
0 0

Sample Output

3
2
5

分析

这是一个树形的DP,使用递归的方法实现。
利用vector数组储存每个节点的孩子节点【直属的下属】
在每一层中利用一个vector用于统计这个下属签字至少需要多少工人,然后使用sort对vector排序
Tip:vector排序使用sort(vector::begin(),vector::end());
之后根据比例T挑选出数量。注意,本题目显然是要求向上取整,因此,使用了技巧C=(k*T-1)/100+1来计算
另外:鉴于本题的树结构,不需要进行记忆化搜索。

样例实现代码

#include<iostream>
#include <fstream>
#include<vector>
#include<algorithm>
#define maxn 100000+5
using namespace std;
vector<int>sons[maxn];
int n,T;
int dp(int u){
    if(sons[u].empty()){
        return 1;
    }
    int k=sons[u].size();
    vector<int>d;
    for(int i=0;i<k;i++){
        d.push_back(dp(sons[u][i]));
    } 
    sort(d.begin(),d.end());
    int c=(k*T-1)/100+1;
    int sum=0;
    for(int i=0;i<c;i++)
        sum+=d[i];
    return sum;
}
int main(){
    int temp;
    ofstream SaveFile("cpp-home.txt");
    while(cin>>n>>T&&n){
        for(int i=0;i<=n;i++)
            sons[i].clear();
        for(int i=1;i<=n;i++){
            cin>>temp;
            sons[temp].push_back(i);
        }
        int ans=dp(0);
        cout<<ans<<endl;        
        SaveFile<<ans<<endl;
    }
    SaveFile.close();
    return 0;
} 

结果

这里写图片描述

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值