C - Cow Hurdles

C - Cow Hurdles

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows’ practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1…N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1…M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.


Input

  • Line 1: Three space-separated integers: N, M, and T
  • Lines 2…M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi
  • Lines M+2…M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

  • Lines 1…T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input
5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1
Sample Output
4
8
-1


题意:一只母牛有t组任务,给你一个包含站点间单向路径的信息图,输出每组任务对应要跨过的最小高度。

解题思路:这题是多源点最短路径问题,很明显是要用我们的Floyd算法,那么此时的状态转移方程还是普通的那个吗?显然不是,此时对母牛来说并不是要计算之间的高度之和,而是从起点到终点的路径中选择需要跨过最高高度最小的那条路径,则状态转移方程为:high[i][j]=min(high[i][j],max(high[i][k],high[k][j]));。那么我们实现起来就很简单了,注意输入要使用scanf输入。


AC代码:

#include<iostream>
#include<cstdio>
#include<cstdlib>
#include<algorithm>
#include<cmath>
#include<string>
#include<stack>
#include<queue>
#include<cstring>
#include<map>
#include<iterator>
#include<list>
#include<set>
#include<functional>

using namespace std;

int t,n,m;//t组测试用例,n个站,m个单向路径
const int maxn=305;
const int inf=0x3f3f3f3f;//表示无穷大。
int high[maxn][maxn];//high[i][j]表示从i到j的高度
int S,E;//起点和终点。
void init(){
	for(int i=1;i<=n;i++){
		for(int j=1;j<=i;j++){
			if(i==j)
				high[i][j]=0;
			else
				high[i][j]=high[j][i]=inf;
		}
	}
}
void floyd(){
	for(int k=1;k<=n;k++){
		for(int i=1;i<=n;i++){
			for(int j=1;j<=n;j++){
				high[i][j]=min(high[i][j],max(high[i][k],high[k][j]));
			}
		}
	}
}
int main(){
	while(cin>>n>>m>>t){
		int u,v,w;
		init();
		for(int i=0;i<m;i++){
			scanf("%d%d%d",&u,&v,&w);
			high[u][v]=w;
		}
		floyd();
		int S,E;
		while(t--){
			scanf("%d%d",&S,&E);
			if(high[S][E]==inf)cout<<"-1"<<endl;
			else cout<<high[S][E]<<endl;
		}
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

unique_pursuit

你的鼓励是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值