poj 2488 A Knight's Journey

A Knight's Journey
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 20870 Accepted: 7050

Description

Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.

Input

The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .

Output

The output for every scenario begins with a line containing "Scenario #i:", where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.

Sample Input

3
1 1
2 3
4 3

Sample Output

Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4

Source

TUD Programming Contest 2005, Darmstadt, Germany


也是一道经典的搜索题,只要注意是按照字典序输出。
#include<iostream>
#include<string.h>
#include<stdio.h>
#define N 27

using namespace std;

int path[N][2];

int flag,a,b;
int map[N][N];

int move[8][2]={-2,-1,-2,1,-1,-2,-1,2,1,-2,1,2,2,-1,2,1};//按照字典序排列

void dfs(int i,int j,int step)
{
    if(step==a*b)//成功条件
    {
        for(int i=0;i<step;i++)
            printf("%c%d",path[i][0]+'A',path[i][1]+1);
        printf("\n");
        flag=1;
    }
    else
    for(int x=0;x<8;x++)
    {
       int n=i+move[x][0];
       int m=j+move[x][1];
        if(n<b&&m<a&&n>=0&&m>=0&&!map[n][m]&&!flag)//在边界内且没有被访问
        {
            map[n][m]=1;
            path[step][0]=n,path[step][1]=m;
          //  cout<<path[step][0]<<path[step][1]<<endl;
            dfs(n,m,step+1);
            map[n][m]=0;//回溯
        }
    }
}

int main()
{
    int k=1,n;
    scanf("%d",&n);
    while(n--)
    {
        flag=0;
        scanf("%d %d",&a,&b);
        for(int i=0;i<a;i++)
           for(int j=0;j<b;j++)
              map[i][j]=0;//初始化地图
        map[0][0]=1;
        path[0][0]=0,path[0][1]=0;//初始化起点
        cout<<"Scenario #"<<k++<<":"<<endl;
        dfs(0,0,1);//搜索
        if(!flag)
            cout<<"impossible"<<endl;
        cout<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 5
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论 5
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值