1490:A Knight‘s Journey(DFS)(大概算普及题)需要回溯

题目
描述
Background
The knight is getting bored of seeing the same black and white squares again and again and has decided to make a journey
around the world. Whenever a knight moves, it is two squares in one direction and one square perpendicular to this. The world of a knight is the chessboard he is living on. Our knight lives on a chessboard that has a smaller area than a regular 8 * 8 board, but it is still rectangular. Can you help this adventurous knight to make travel plans?

Problem
Find a path such that the knight visits every square once. The knight can start and end on any square of the board.
输入
The input begins with a positive integer n in the first line. The following lines contain n test cases. Each test case consists of a single line with two positive integers p and q, such that 1 <= p * q <= 26. This represents a p * q chessboard, where p describes how many different square numbers 1, . . . , p exist, q describes how many different square letters exist. These are the first q letters of the Latin alphabet: A, . . .
输出
The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line containing the lexicographically first path that visits all squares of the chessboard with knight moves followed by an empty line. The path should be given on a single line by concatenating the names of the visited squares. Each square name consists of a capital letter followed by a number.
If no such path exist, you should output impossible on a single line.
样例输入
3
1 1
2 3
4 3
样例输出
Scenario #1:
A1

Scenario #2:
impossible

Scenario #3:
A1B3C1A2B4C2A3B1C3A4B2C4
注意:字典顺序排列,还有回溯问题

#include <bits/stdc++.h>
using namespace std;
int to[8][2]={-1,-2,1,-2,-2,-1,2,-1,-2,1,2,1,-1,2,1,2};//由题知字典顺序排列 so注意这里的顺序不能改变
int vis[30][30];//标记走过的位置 
int p,q,success,num;
struct path{
	int x,y;
}path[30];
void dfs(int x,int y,int num){
	path[num].x =x;
	path[num].y =y;
	if(num==p*q-1){
		success=1;
		return;
	}
	for(int i=0;i<8;i++){
		int xx=x+to[i][0],yy=y+to[i][1];
		if(xx>0&&yy>0&&xx<=p&&yy<=q&&!vis[xx][yy]&&!success){
			vis[xx][yy]=1;
			dfs(xx,yy,num+1);//注意这里的num不能写成++num!!!因为回溯问题如果这样写应该在它的后面加上--num 
			vis[xx][yy]=0;//回溯 
		}
	}
}
int main(){
	int n;
	cin>>n;
	for(int i=1;i<=n;i++){
		cin>>p>>q;
		success=0,num=0;//可能不止一组需要每次进行初始化 
		for(int a=1;a<=p;a++){
			for(int b=1;b<=q;b++){
				vis[a][b]=0;
			}
		}
		vis[1][1]=1;//按字典顺序所以应该从(1,1)的位置开始走,即A1 
		dfs(1,1,0);
		printf("Scenario #%d:\n",i);
		if(success){
			for(int j=0;j<p*q;j++){
				printf("%c%d",path[j].y+'A'-1,path[j].x);
			}
			cout<<endl;
		}
		else cout<<"impossible"<<endl;
		cout<<endl;
	}
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值