"Fibonacci"(0506)

Description

Input consists of a sequence of lines, each containing an integer n. (n < 1,000,000,000).

Input

Print the word "yes" if 3 divide evenly into F(n). Print the word "no" if not.

Output
1
2
3
4
5
6
7
0
1
2
3
4
5
Sample Input
1
2
3
4
5
6
no
no
yes
no
no
no
Sample Output
#include<stdio.h>
int main()
{
    long n;
     
    while(scanf("%d",&n)!=EOF)
    {  
        if(n<0)
            break;
        if((n+2)%4==0)
            printf("yes\n");
        else
            printf("no\n");
    }
 
    return 0;
}

水水更健康,从F(2)开始每4项就有一项能3整除,17行代码。。好简洁的说

以下是转载的代码,请尊重原创!

#include <iostream>
#include <stdio.h>
using namespace std;

int f[1000100];
int main()
{
f[0]=1; f[1]=2;
int n;
while(scanf("%d",&n)!=EOF)
{
for(int i=2;i<=n;i++)
{
f[i] = (f[i-1]+f[i-2])%3;
}
if(f[n]%3==0)
printf("yes\n");
else
printf("no\n");
}
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值