(3) J2SE 5.0 的 JAVA_HOME 配置问题

原创 2005年02月28日 11:06:00
这个问题已经困挠我好些天了,一直想不通怎么一回事。我用的操作系统是Windows 2000 Professional.
我机器上原本安装着 j2sdk1.4.2_07,在系统变量里面设置了
JAVA_HOME = c:/Program Files/JAVA/j2sdk1.4.2_07
Path = c:/Program Files/JAVA/j2sdk1.4.2_07
在 cmd 中 java -version,一切正常告诉我是 J2SDK 1.4.2_07

奇怪的事情是在安装 jdk1.5.0_01 的时候发生的,装完以后,没有配置任何的JAVA_HOME参数和Path参数。
在 cmd 中 java -version,告诉我了现在的版本是 j2sdk1.5.0_01。
开始以为它想Oracle一样在系统变量中自动添加了相关的Path等参数,不过我仔细的找了一遍没有发现。

我想系统中的默认 JAVA_HOME 还是用 j2sdk1.4.2,j2sdk1.5.0 只是想在 Eclipse 3.1M4 中做一些测试而已,我应该怎么配置呢?!

有人碰到过这种问题吗?!



下定决心,不怕牺牲,排除万难,争取胜利

My productivity Workstation (转自http://kgionline.com)
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
PrimeJava
user26433.gif
我思故我在

star2.gifstar2.gifstar1.gifstar1.gifstar1.gif

发贴: 110
积分: 13
pixel.gif
post.gif于 2005-02-25 15:46 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard.   ie only, sorry for netscape users:-)add this post to my favorite list
http://www.cjsdn.net/post/view?bid=1&id=128247&sty=1&tpg=1&age=0

不知道对你有没有帮助。



欲做精金美玉的人品,定从烈火中煅来;
思立掀天揭地的事功,需向薄冰上履过。

天将降大任与斯人也,必先苦其心志,劳其筋骨,饿其体肤,空乏其身,行拂乱其所为,所以动心忍性,增益其所不能。

We grow neither better nor worse as we grow old but more like ourselves.

学习SWT最好的资源
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
leowu2000
user9329.gif


版主
xing8.gif

发贴: 148
积分: 11
pixel.gif
post.gif于 2005-02-25 16:12 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard.   ie only, sorry for netscape users:-)add this post to my favorite list
Path = c:/Program Files/JAVA/j2sdk1.4.2_07
???
应该加上bin。



Eclipse邮件列表

IDEA 4.5.4已经发布了。
作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
logix
face_image56.gif
莫等闲,白了少年头

star2.gifstar1.gifstar1.gifstar1.gifstar1.gif

发贴: 51
积分: 0
pixel.gif
post_n.gif于 2005-02-27 19:46 user profilesend a private message to usersend email to logixreply to postsearch all posts byselect and copy to clipboard.   ie only, sorry for netscape users:-)add this post to my favorite list
嗯,我也有同样的困扰,公司的产品要基于1.4开发,我又想试试1.5。不过PrimeJava 提到的那篇文章写的很好,问题基本解决,可以通过改path切换。现在就是applet runtime好像还是有点问题。


作者 Re:J2SE 5.0 的 JAVA_HOME 配置问题,郁闷了 [Re:jianhua23]
jianhua23
face_p12.gif
冰冰

star2.gifstar1.gifstar1.gifstar1.gifstar1.gif

发贴: 68
积分: 40
pixel.gif
post_n.gif于 2005-02-28 09:39 user profilesend a private message to userreply to postsearch all posts byselect and copy to clipboard.   ie only, sorry for netscape users:-)add this post to my favorite list
Path 的那个bin是加的,前面是疏忽,没有写。
好了,基本上搞定但是还有一个小问题,我来写一下吧。
当你在安装 1.5.0 j2sdk 的时候,如果选择了 public jre 的话,他会取代掉原先的 1.4.2_07 的 public jre,你在注册表里面可以看到。
--------------------------------------------------------------------------------------
HKEY_LOCAL_MACHINE/Software/JavaSoft/Java Runtime Environment
值为 1.5
--------------------------------------------------------------------------------------
如果把它改成 1.4.2_07 的话(并把所有的相应参数都改为 1.4.2_07),会报出如下错误:
--------------------------------------------------------------------------------------
has value '1.4', but '1.5' is required
--------------------------------------------------------------------------------------
但解决方法也很简单,只安装一个 j2sdk 1.4.2_07 的 public jre,j2sdk 1.5.0_01 不安装 public jre。
部署两个 Eclipse,Eclipse 3.0.1 的 jre 路径指向 j2sdk 1.4.2_07 的 jre,Eclipse 3.1M4 的 jre 路径指向 j2sdk 1.5.0_01/jre 就万事 OK 了。
谢谢大家的帮助 Big Smile



下定决心,不怕牺牲,排除万难,争取胜利

用了Wallop后的猜想!

Android 5.0的特性

-
  • 1970年01月01日 08:00

建枚举类时出现“Project '**' is not a J2SE 5.0 compliant project.”问题怎么办?

首先要确定是不是程序问题,如果不是程序问题,那可能是Eclipse设置有问题,而Eclipse可以指定编译深度,Eclipse设置默认值是1.4,可以将它改成5.0或者以上版本,方法是Window->...
  • pan_yeju
  • pan_yeju
  • 2015-10-06 09:10:47
  • 1375

Project 'Annotation' is not a J2SE 5.0 compliant project.

Project 'Annotation' is not a J2SE 5.0 compliant project. 解决方法1:https://www.genuitec.com/forums/top...
  • KrystalBm
  • KrystalBm
  • 2016-11-17 15:43:02
  • 572

[Java2开发平台标准版5.0].[J2SE.Development.Kit.5.0].jdk-1.5.0.exe

  • 2013年10月12日 08:06
  • 43.93MB
  • 下载

J2SE5.0中文版API

  • 2008年11月21日 14:35
  • 19.07MB
  • 下载

Java使用eclipse新建枚举报出, 项目“xxxxx”不是符合 J2SE 5.0 的项目。的解决办法

在eclipse新建的枚举报出 项目“XXXX”不是符合 J2SE 5.0 的项目。这样的 错误,结果可能是编译器的版本的问题,也可能是你JDK版本的 问题。解决这个问题你可以按照如下的步骤来实现: ...
  • he_min
  • he_min
  • 2015-09-02 20:44:16
  • 1357

Java Runtime Environment (JRE) 5.0 Update 21

  • 2009年10月01日 17:12
  • 16.66MB
  • 下载

J2SE 5.0 API [2] (中文版)

  • 2008年07月28日 18:32
  • 9.54MB
  • 下载

NetBeans 5.0 + J2SE 5.0 Update 6 安装软件包(Windows Platform)

  • 2007年03月21日 14:20
  • 132MB
  • 下载

NetBeans IDE 5.5 J2SE(TM) Development Kit (JDK) 版本 5.0 下载

http://www.netbeans.org/kb/55/quickstart_zh_CN.htmlNetBeans IDE 5.5 快速入门指南欢迎使用 NetBeans IDE!本教程通过向您介...
  • laolaowhn
  • laolaowhn
  • 2008-01-15 19:49:00
  • 2841
收藏助手
不良信息举报
您举报文章:(3) J2SE 5.0 的 JAVA_HOME 配置问题
举报原因:
原因补充:

(最多只允许输入30个字)