ZOJ-3956 Course Selection System (01背包,dp)

代码参考博客链接 

 

Description

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1, x2, ..., xm, then his comfort level of the semester can be defined as follows: 

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

 

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input

2
3
10 1
5 1
2 10
2
1 10
2 10

Sample Output

191
0

Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

补题的时候补到这题,比赛的时候我们没开这题!!亏了呜呜呜 

【题目分析】

这个题目给的公式就是吓唬吓唬人的~$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

简化:  记  A = 求和H, B = 求和C,公式:舒适值 = A^2 - A*B- B^2 = A*(A - B) - B^2,求舒适值最大的情况~

舒适值最低为 0 ,一门课都不选,当 A > B的时候才有选课,A越大越好,B越小越好

具体看代码注释~


#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <map>
#include <list>
#include <vector>
#include <stack>
#include <queue>
#include <algorithm>
#include <iostream>
#define go(i,a,b) for(int i=a;i<=b;i++)
#define og(i,a,b) for(int i=a;i>=b;i--)
#define mem(a) memset(a,0,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
//const int maxn = 1e6 + 5;
typedef long long ll;
struct node
{
    int a,b;
}s[505];
ll dp[50010];//happiness值
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        int sum=0;
        memset(dp,0,sizeof(dp));
        go(i,0,n-1)
        {
            scanf("%d%d",&s[i].a,&s[i].b);
            sum+=s[i].b;
        }
        go(i,0,n-1)
            og(j,sum,s[i].b)
                dp[j]=max(dp[j],dp[j-s[i].b]+s[i].a);//max(不选第i个课程时的快乐值,选了第i个课程时的快乐值)
        ll maxn=0;
        //下面是我觉得最巧妙的地方!!不用再去求和
        go(i,0,sum)//注意循环的是选的不同的课的credit的sum值
            maxn=max(maxn,dp[i]*dp[i]-dp[i]*i-i*i);//maxn(不选第i个课的舒适值,选第i个课程舒适值)
        printf("%lld\n",maxn);
    }
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值