ZOJ - 3956 Course Selection System(01背包)

题目链接:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=3956点击打开链接

Course Selection System

Time Limit: 1 Second       Memory Limit: 65536 KB

There are n courses in the course selection system of Marjar University. The i-th course is described by two values: happiness Hi and credit Ci. If a student selects m courses x1x2, ..., xm, then his comfort level of the semester can be defined as follows: 

$$(\sum_{i=1}^{m} H_{x_i})^2-(\sum_{i=1}^{m} H_{x_i})\times(\sum_{i=1}^{m} C_{x_i})-(\sum_{i=1}^{m} C_{x_i})^2$$

Edward, a student in Marjar University, wants to select some courses (also he can select no courses, then his comfort level is 0) to maximize his comfort level. Can you help him?

Input

There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains a integer n (1 ≤ n ≤ 500) -- the number of cources.

Each of the next n lines contains two integers Hi and Ci (1 ≤ Hi ≤ 10000, 1 ≤ Ci ≤ 100).

It is guaranteed that the sum of all n does not exceed 5000.

We kindly remind you that this problem contains large I/O file, so it's recommended to use a faster I/O method. For example, you can use scanf/printf instead of cin/cout in C++.

Output

For each case, you should output one integer denoting the maximum comfort.

Sample Input
2
3
10 1
5 1
2 10
2
1 10
2 10
Sample Output
191
0
Hint

For the first case, Edward should select the first and second courses.

For the second case, Edward should select no courses.

h越大值越大 c越大值越小
这样h就是value c就是weight
01背包 最后带入公式判断最大情况

#include <iostream>
#include <algorithm>
#include <cstring>
#include <vector>
#include <stdio.h>
#define maxn 2005
using namespace std;
struct xjy
{
    long long int h;
    long long int c;
};
vector<xjy > s;

int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        long long int m;long long int sum=0;
        long long int dp[55555];
        memset(dp,0,sizeof(dp));
        s.clear();
        scanf("%lld",&m);
        for(int i=1;i<=m;i++)
        {
            xjy mid;
            scanf("%lld%lld",&mid.h,&mid.c);
            s.push_back(mid);
            sum+=mid.c;
        }
        for(int i=0;i<m;i++)
        {
           for(int j=sum;j>=s[i].c;j--)
                dp[j]=max(dp[j],dp[j-s[i].c]+s[i].h);
        }
        long long int ans=0;
        for(int i=1;i<=sum;i++)
            ans=max(ans,dp[i]*dp[i]-dp[i]*i-i*i);
        printf("%lld\n",ans);
    }
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值