HDU2026

首字母变大写

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 49163    Accepted Submission(s): 27145


Problem Description
输入一个英文句子,将每个单词的第一个字母改成大写字母。
 

Input
输入数据包含多个测试实例,每个测试实例是一个长度不超过100的英文句子,占一行。
 

Output
请输出按照要求改写后的英文句子。
 

Sample Input
  
  
i like acm i want to get an accepted
 

Sample Output
  
  
I Like Acm I Want To Get An Accepted

 



#include <stdio.h>
#include <string.h>


int main()
{
  char a[105];
  int i;

  while(gets(a))
  {
<span style="white-space:pre">	</span>int len;

<span style="white-space:pre">	</span>len=strlen(a);

<span style="white-space:pre">	</span>if(a[0]!=' ')
<span style="white-space:pre">		</span>printf("%c",a[0]-32);

<span style="white-space:pre">	</span>for(i=1;i<len;i++)
<span style="white-space:pre">	</span>{
<span style="white-space:pre">	</span>    if(a[i-1]==' ' && (a[i]>='a' && a[i]<='z'))
<span style="white-space:pre">	</span>   <span style="white-space:pre">	</span>printf("%c",a[i]-32);
<span style="white-space:pre">	</span>    else
<span style="white-space:pre">		</span>printf("%c",a[i]);
<span style="white-space:pre">	</span>}
<span style="white-space:pre">	</span>putchar('\n');
  }
return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值