HDU2709 Sumsets

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 2484    Accepted Submission(s): 1001


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6


当i为奇数的时候 a[i]=a[i-1];相当于在前一个数的加数后面都加上一;

当i为偶数的时候啊a[i]=a[i-2]+a[i>>1]:

1)加数里含有1,则一定含有两个1,相当于a[i-2]的加数里加上两个一,a[i-2]种;

2)加数里不含1,则相当于i/2 的加数都乘以2,a[i>>2]种

因此 a[i]=a[i-2]+a[i>>1];


#include <stdio.h>

int a[1000005] = {1,1,2};

int main(){
	int n;
		
	
	
	for(int i = 3; i <= 1000000; i ++){
		if(i % 2 == 0)
			a[i] = (a[i - 1] + a[i / 2]) % 1000000000;
		else
			a[i] = a[i - 1];
	}
	
	while(~scanf("%d",&n)){
	
		printf("%d\n",a[n]);
	}
	
	return 0;
} 


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值