hdu2709(DP)

Sumsets

Time Limit: 6000/2000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1294    Accepted Submission(s): 495


Problem Description
Farmer John commanded his cows to search for different sets of numbers that sum to a given number. The cows use only numbers that are an integer power of 2. Here are the possible sets of numbers that sum to 7:

1) 1+1+1+1+1+1+1
2) 1+1+1+1+1+2
3) 1+1+1+2+2
4) 1+1+1+4
5) 1+2+2+2
6) 1+2+4

Help FJ count all possible representations for a given integer N (1 <= N <= 1,000,000).
 

Input
A single line with a single integer, N.
 

Output
The number of ways to represent N as the indicated sum. Due to the potential huge size of this number, print only last 9 digits (in base 10 representation).
 

Sample Input
  
  
7
 

Sample Output
  
  
6
 

Source
 

Recommend
teddy   |   We have carefully selected several similar problems for you:   2716  2571  2600  2721  2177 
            本题要求所给数的加数组合,其中加数为2的整数幂。数据量很大,所有暗示有O(n)的算法。
          dp[1]=1,dp[2]=2.
         当n为奇数时,必含有一个加数1,此时dp[n]=dp[n-1];
         当n为偶数时,要么不含1,至少含有两个1,此时dp[n]=dp[n-2]+dp[n/2],不含1与n/2时等价,至少含2个1与dp[n-2]等价。
#include<iostream>
using namespace std;

const int MAXN=1000000+100;
const int MOD=1000000000;

__int64 dp[MAXN];


void DP()
{
	memset(dp,0,sizeof(dp));
	dp[1]=1;
	dp[2]=2;
	for(int i=3;i<=1000001;i++)
	{
		if(0==i%2)
			dp[i]=(dp[i-2]+dp[i/2])%MOD;
		else dp[i]=dp[i-1];
	}
}

int main()
{
	int n;
	DP();
	while(~scanf("%d",&n))
		printf("%I64d\n",dp[n]);
	return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值