HDU1213 How Many Tables

13 篇文章 0 订阅

How Many Tables

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 27986    Accepted Submission(s): 13880


Problem Description
Today is Ignatius' birthday. He invites a lot of friends. Now it's dinner time. Ignatius wants to know how many tables he needs at least. You have to notice that not all the friends know each other, and all the friends do not want to stay with strangers.

One important rule for this problem is that if I tell you A knows B, and B knows C, that means A, B, C know each other, so they can stay in one table.

For example: If I tell you A knows B, B knows C, and D knows E, so A, B, C can stay in one table, and D, E have to stay in the other one. So Ignatius needs 2 tables at least.
 

Input
The input starts with an integer T(1<=T<=25) which indicate the number of test cases. Then T test cases follow. Each test case starts with two integers N and M(1<=N,M<=1000). N indicates the number of friends, the friends are marked from 1 to N. Then M lines follow. Each line consists of two integers A and B(A!=B), that means friend A and friend B know each other. There will be a blank line between two cases.
 

Output
For each test case, just output how many tables Ignatius needs at least. Do NOT print any blanks.
 

Sample Input
  
  
2 5 3 1 2 2 3 4 5 5 1 2 5
 

Sample Output
  
  
2 4
 

Author
Ignatius.L
 

Source

并查集的模板题目,关于一些并查集的讲解,给出两个链接 并查集讲解并查集讲解2

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int n,m,t;
int par[1005];

int find(int x){
	if(par[x] == x)
		return x;
	return find(par[x]);
}

void UniteSet(int u, int v){
	int x = find(u);
	int y = find(v);
	
	if(x == y)
		return ;
	else
		par[x] = y;
}

int main(){
	scanf("%d",&t);
	while(t --){
		scanf("%d%d",&n,&m);
		for(int i = 1; i <= n; i ++){
			par[i] = i;
		}	
		int u,v;
		while(m --){
			scanf("%d%d",&u,&v);
			UniteSet(u,v);
		}
		
		int cnt = 0;
		for(int i = 1; i <= n; i ++){
			if(i == par[i])
				cnt ++;
		}
		printf("%d\n",cnt);
	}
	return 0;
}




  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值