HDU1385 Minimum Transport Cost

Minimum Transport Cost

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10544    Accepted Submission(s): 2929


Problem Description
These are N cities in Spring country. Between each pair of cities there may be one transportation track or none. Now there is some cargo that should be delivered from one city to another. The transportation fee consists of two parts: 
The cost of the transportation on the path between these cities, and

a certain tax which will be charged whenever any cargo passing through one city, except for the source and the destination cities.

You must write a program to find the route which has the minimum cost.
 

Input
First is N, number of cities. N = 0 indicates the end of input.

The data of path cost, city tax, source and destination cities are given in the input, which is of the form:

a11 a12 ... a1N
a21 a22 ... a2N
...............
aN1 aN2 ... aNN
b1 b2 ... bN

c d
e f
...
g h

where aij is the transport cost from city i to city j, aij = -1 indicates there is no direct path between city i and city j. bi represents the tax of passing through city i. And the cargo is to be delivered from city c to city d, city e to city f, ..., and g = h = -1. You must output the sequence of cities passed by and the total cost which is of the form:
 

Output
From c to d :
Path: c-->c1-->......-->ck-->d
Total cost : ......
......

From e to f :
Path: e-->e1-->..........-->ek-->f
Total cost : ......

Note: if there are more minimal paths, output the lexically smallest one. Print a blank line after each test case.

 

Sample Input
  
  
5 0 3 22 -1 4 3 0 5 -1 -1 22 5 0 9 20 -1 -1 9 0 4 4 -1 20 4 0 5 17 8 3 1 1 3 3 5 2 4 -1 -1 0
 

Sample Output
  
  
From 1 to 3 : Path: 1-->5-->4-->3 Total cost : 21 From 3 to 5 : Path: 3-->4-->5 Total cost : 16 From 2 to 4 : Path: 2-->1-->5-->4 Total cost : 17
 

Source

题目大意为在一个国家有n个城市,每个城市之间要么有一条道路要么没有,通过某一城市的时候必须要交
    相应的关税(不计出发地和目的地),求在两个城市之间运输货物的最小费用。

但撇开输出路径,其实就是一道floyd模板题目,关于floyd记录路径,用path[i][j]记录当前的后继,即path[i][j]=j; 在进行最短路径的记录的时候,首先path[i][j]记录的是从i到j的最短路径中间的第一个结点,也就是path[i][k]的后继k,用path[i][j]记录下k,每次查找最短路径的时候都记录下path[i][k]的后继,在进行输出的时候,因为记录的是path[i][k]的后继k,所以也就是记录下了path[k][j]的前驱, 所以只需令next=path[next][j],因为剩下的最短路径一定是path[k][j]这个路径。 


#include <cstdio>
#include <cstring>
#include <algorithm>
#define INF 100000005
using namespace std;

int map[105][105],b[105],path[105][105];
int n;

void floyd(){
	for(int k = 1; k <= n; k ++){
		for(int i = 1; i <= n; i ++){
			for(int j = 1; j <= n; j ++){
				if(map[i][j] > map[i][k] + map[k][j] + b[k]){
					map[i][j] = map[i][k] + map[k][j] + b[k];
					path[i][j] = path[i][k]; //记录路径path[i][k]的后继 
				}
				else if(map[i][j] == map[i][k] + map[k][j] + b[k] && path[i][j] > path[i][k]){//j>k;
					path[i][j] = path[i][k]; //每次要选择字典序小的路径 
				}
			}
		}
	}
}

int main(){
	while(~scanf("%d",&n) && n){
		memset(path,-1,sizeof(path));
		for(int i = 1; i <= n; i ++){
			for(int j = 1; j <= n; j ++){//对map[][]以及path[][]进行初始化 
				scanf("%d",&map[i][j]);
				if(map[i][j] == -1)
					map[i][j] = INF;
				else
					path[i][j] = j;			
			}
		}
		for(int i = 1; i <= n; i ++)
			scanf("%d",&b[i]);
		floyd(); //调用floyd算法 
		int u,v;
		while(~scanf("%d%d",&u,&v)){
			if(u == -1 && v == -1)
				break;
			printf("From %d to %d :\n",u,v);
			printf("Path: ");
			printf("%d",u);
			if(u == v){ //起点和终点是同一个点时,直接输出即可 
				printf("\n");
			}
			else{
				int next = path[u][v]; //u,v之间的第一个中间结点 
				while(next != v){
					printf("-->%d",next);
					next = path[next][v];
				}
				printf("-->%d\n",v);
			}
			printf("Total cost : %d\n\n",map[u][v]);
		}
		
		printf("\n****************\n");
		for(int i = 1; i <= n; i ++){
			for(int j = 1; j <= n; j ++)
				printf("%3d",path[i][j]);
			printf("\n");
		}
	}
	return 0;
}


  • 0
    点赞
  • 2
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值