HDU2120 Ice_cream's world I

13 篇文章 0 订阅

Ice_cream's world I


Time Limit: 3000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1521    Accepted Submission(s): 905


Problem Description
ice_cream's world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.
 

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.
 

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.
 

Sample Input
  
  
8 10 0 1 1 2 1 3 2 4 3 4 0 5 5 6 6 7 3 6 4 7
 

Sample Output
  
  
3
 

Author
Wiskey
 

Source


并查集判环的问题,思路很简单,如果一个图再输入一条边就变成了环,则这条边的两个顶点一定有同一个根节点。

#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;

int par[1005],n,m,cnt;

int find(int x){
	if(x == par[x])
		return x;
	return par[x] = find(par[x]);
}

void UnionSet(int a, int b){
	int x = find(a);
	int y = find(b);
	
	if(x != y)
		par[x] = y;
	else
		cnt ++;//对于一个环来说,如果最后输入的一条边恰好能够使其变成环,则该边的两个结点应该是同一个父节点 
}

int main(){
	while(~scanf("%d%d",&n,&m)){
		for(int i = 0; i < n; i ++)
			par[i] = i;
		cnt = 0;
		
		int a,b;
		while(m --){
			scanf("%d%d",&a,&b);
			UnionSet(a,b);
		}
		printf("%d\n",cnt);
	}
	return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值