【HDU 2120 Ice_cream's world I】

Ice_cream’s world I

Problem Description
ice_cream’s world is a rich country, it has many fertile lands. Today, the queen of ice_cream wants award land to diligent ACMers. So there are some watchtowers are set up, and wall between watchtowers be build, in order to partition the ice_cream’s world. But how many ACMers at most can be awarded by the queen is a big problem. One wall-surrounded land must be given to only one ACMer and no walls are crossed, if you can help the queen solve this problem, you will be get a land.

Input
In the case, first two integers N, M (N<=1000, M<=10000) is represent the number of watchtower and the number of wall. The watchtower numbered from 0 to N-1. Next following M lines, every line contain two integers A, B mean between A and B has a wall(A and B are distinct). Terminate by end of file.

Output
Output the maximum number of ACMers who will be awarded.
One answer one line.

Sample Input
8 10
0 1
1 2
1 3
2 4
3 4
0 5
5 6
6 7
3 6
4 7

Sample Output
3

#include<cstdio>
#define K 10011
int st[K],ans=0;
int find(int p)
{
    int ch=p;
    int t;
    while(p!=st[p])
    p=st[p];
    while(ch!=p)
    {
        t=st[ch];
        st[ch]=p;
        ch=t;
    }
    return p;
}
void node(int x,int y)
{
    int fx=find(x);
    int fy=find(y);
    if(fx!=fy)
    st[fx]=fy;
    else
    ans++;
}
int main()
{
    int N,M,a,b,i;
    while(scanf("%d%d",&N,&M)!=EOF)
    {
        for(i=0;i<=N;i++)
        st[i]=i;
        while(M--)
        {
            scanf("%d%d",&a,&b);
            node(a,b);
        }
        printf("%d\n",ans);
        ans=0;
    }
    return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值