Wireless Network
Time Limit: 10000MS | Memory Limit: 65536K | |
Total Submissions: 27279 | Accepted: 11286 |
Description
An earthquake takes place in Southeast Asia. The ACM (Asia Cooperated Medical team) have set up a wireless network with the lap computers, but an unexpected aftershock attacked, all computers in the network were all broken. The computers are repaired one by one, and the network gradually began to work again. Because of the hardware restricts, each computer can only directly communicate with the computers that are not farther than d meters from it. But every computer can be regarded as the intermediary of the communication between two other computers, that is to say computer A and computer B can communicate if computer A and computer B can communicate directly or there is a computer C that can communicate with both A and B.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
In the process of repairing the network, workers can take two kinds of operations at every moment, repairing a computer, or testing if two computers can communicate. Your job is to answer all the testing operations.
Input
The first line contains two integers N and d (1 <= N <= 1001, 0 <= d <= 20000). Here N is the number of computers, which are numbered from 1 to N, and D is the maximum distance two computers can communicate directly. In the next N lines, each contains two integers xi, yi (0 <= xi, yi <= 10000), which is the coordinate of N computers. From the (N+1)-th line to the end of input, there are operations, which are carried out one by one. Each line contains an operation in one of following two formats:
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
1. "O p" (1 <= p <= N), which means repairing computer p.
2. "S p q" (1 <= p, q <= N), which means testing whether computer p and q can communicate.
The input will not exceed 300000 lines.
Output
For each Testing operation, print "SUCCESS" if the two computers can communicate, or "FAIL" if not.
Sample Input
4 1 0 1 0 2 0 3 0 4 O 1 O 2 O 4 S 1 4 O 3 S 1 4
Sample Output
FAIL SUCCESS
Source
POJ Monthly,HQM
题意:有n台电脑,经过一次地震后需要对这些电脑进行修复,“O”操作表示修复某台电脑,“S”操作表示判断p和q两台电脑之间是否连通。其中输入的n表示电脑的数量,d表示两台电脑能够通信的最大距离。
思路:并不是很难的一道并查集题目,用b[]数组保存输入的电脑的编号,每次修复一台电脑的时候就把该台电脑与其他已经修复好的电脑进行比较,如过两者之间的距离小于等于要求的最大距离,则两者可以合并到一个集合中。
#include <cstdio>
#include <cstring>
using namespace std;
int n,d,b[300005],par[1005],Rank[1005];
struct node{
int x,y;
}p[1005];
int distance(int u, int v){
return ((p[u].x - p[v].x) * (p[u].x - p[v].x) + (p[u].y - p[v].y) * (p[u].y - p[v].y));
}
int find_set(int x){
if(x == par[x])
return x;
return par[x] = find_set(par[x]);
}
void UnoinSet(int u, int v){
int x = find_set(u);
int y = find_set(v);
if(x != y){
if(Rank[x] > Rank[y])
par[y] = x;
else{
par[x] = y;
if(Rank[x] == Rank[y])
Rank[y] ++;
}
}
}
int main(){
scanf("%d%d",&n,&d);
for(int i = 1; i <= n; i ++){
scanf("%d%d",&p[i].x,&p[i].y);
par[i] = i;
Rank[i] = 0;
}
char ch;
int p,q,k=0;
getchar();//吸收回车
while(~scanf("%c",&ch)){
if(ch == 'O'){
scanf("%d",&p);
for(int i = 0; i < k; i ++){
if(distance(b[i],p) <= d * d)//判断两点之间的距离是否小于等于要求的最大距离,是则合并
UnoinSet(b[i],p);
}
b[k ++] = p;
}
else{
scanf("%d%d",&p,&q);
int x = find_set(p);
int y = find_set(q);
if(x == y)//两者在一个集合中,则证明连通
printf("SUCCESS\n");
else
printf("FAIL\n");
}
getchar();//吸收回车
}
return 0;
}