HDU1709 The Balance(母函数)

The Balance

 

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 8025    Accepted Submission(s): 3343

 

 

Problem Description

Now you are asked to measure a dose of medicine with a balance and a number of weights. Certainly it is not always achievable. So you should find out the qualities which cannot be measured from the range [1,S]. S is the total quality of all the weights.

 

 

Input

The input consists of multiple test cases, and each case begins with a single positive integer N (1<=N<=100) on a line by itself indicating the number of weights you have. Followed by N integers Ai (1<=i<=N), indicating the quality of each weight where 1<=Ai<=100.

 

 

Output

For each input set, you should first print a line specifying the number of qualities which cannot be measured. Then print another line which consists all the irrealizable qualities if the number is not zero.

 

 

Sample Input

 

3 1 2 4 3 9 2 1

 

 

Sample Output

 

0 2 4 5

 

 

Source

HDU 2007-Spring Programming Contest

 

 

思路:构造母函数G(x) = (1+x^a[0])(1+x^a[1])+.......,最后要考虑当天平的左右都存在砝码时的情况,例如在第二个例子中,当天平的左边有3,右边有9,则能够称量出6.所以最后要计算各个差值。

 

 

 

#include <cstdio>
#include <cstring>
using namespace std;

int n,a[105],c1[10005],c2[10005];

int main(){
	while(~scanf("%d",&n)){
		int sum = 0;
		for(int i = 0; i < n; i ++){
			scanf("%d",&a[i]);
			sum += a[i];
		}
		memset(c1,0,sizeof(c1));
		memset(c2,0,sizeof(c2));
		
		c1[0] = c1[a[0]] = 1;//对第一个表达式进行初始化 
		
		for(int i = 1; i < n; i ++){//对其余表达式进行计算 
			for(int j = 0; j <= sum; j ++){//计算原先c1[]中的元素 
				if(c1[j]){
					for(int k = 0; k <= a[i]; k += a[i]){//计算当前的元素 
						if(k + j <= sum){//计算两者的乘积 
							c2[k+j] += c1[j];
						}
					}
				}
			}
			
			for(int j = 0; j <= sum; j ++){
				c1[j] = c2[j];
				c2[j] = 0;
			}
		}
		
		for(int i = sum; i >= sum/2; i --){//一开始i>=0超时,改成i>=sum/2就过了 
			if(c1[i]){//计算当左右都存在砝码时的情况 
				for(int j = 0; j <= i; j ++){
					if(c1[j])
						c2[i-j] ++;
				}
			}
		}
		
		int cnt = 0;
		for(int i = 0; i <= sum; i ++){//计算不能够称量的数量 
			if(!c2[i])
				cnt ++;
		}
		printf("%d\n",cnt);
		if(cnt){
			for(int i = 0; i <= sum; i ++){
				if(!c2[i]){
					printf("%d",i);
					cnt --;
					if(cnt)
						printf(" ");	
				}
			}
			printf("\n");
		}
	}
	return 0;
}

 

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值