HDU4027 Can you answer these queries? (线段树)

Can you answer these queries?

Time Limit: 4000/2000 MS (Java/Others)    Memory Limit: 65768/65768 K (Java/Others)
Total Submission(s): 19070    Accepted Submission(s): 4501


Problem Description
A lot of battleships of evil are arranged in a line before the battle. Our commander decides to use our secret weapon to eliminate the battleships. Each of the battleships can be marked a value of endurance. For every attack of our secret weapon, it could decrease the endurance of a consecutive part of battleships by make their endurance to the square root of it original value of endurance. During the series of attack of our secret weapon, the commander wants to evaluate the effect of the weapon, so he asks you for help.
You are asked to answer the queries that the sum of the endurance of a consecutive part of the battleship line.

Notice that the square root operation should be rounded down to integer.
 

Input
The input contains several test cases, terminated by EOF.
  For each test case, the first line contains a single integer N, denoting there are N battleships of evil in a line. (1 <= N <= 100000)
  The second line contains N integers Ei, indicating the endurance value of each battleship from the beginning of the line to the end. You can assume that the sum of all endurance value is less than 2 63.
  The next line contains an integer M, denoting the number of actions and queries. (1 <= M <= 100000)
  For the following M lines, each line contains three integers T, X and Y. The T=0 denoting the action of the secret weapon, which will decrease the endurance value of the battleships between the X-th and Y-th battleship, inclusive. The T=1 denoting the query of the commander which ask for the sum of the endurance value of the battleship between X-th and Y-th, inclusive.
 

Output
For each test case, print the case number at the first line. Then print one line for each query. And remember follow a blank line after each test case.
 

Sample Input
  
  
10 1 2 3 4 5 6 7 8 9 10 5 0 1 10 1 1 10 1 1 5 0 5 8 1 4 8
 

Sample Output
  
  
Case #1: 19 7 6
 

Source


题意通俗的来讲就是这样:有n个数,存在两种操作,①是查询②是修改,当t==1时,求的是从x到y的区间和,当t==0时,把区间[x,y]中的每个数变成原先的开方根。

思路:数据的范围是2^63次方,也就是说开平方最多开7次,如果区间里的任何一个数都是1,则就没有必要再对区间中的数开平方,在利用线段树进行区间更新时,每次更新非1的叶子节点即可。

反思:   ①开方后是向下取整

              ②PE一次,注意每组测试事例后换行.....

              ③手残一发,把sum[rt] = a[l] 写成了sum[rt] = a[rt].....

注意题目要求!!!注意不要手残!!!

AC代码如下:

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
#define LL long long
#define ls rt << 1
#define rs rt << 1 | 1
using namespace std;

const int maxn = 1e5 + 10;
LL n,m,sum[maxn<<2],a[maxn];
int cas = 0;

void pushup(LL rt){
	sum[rt] = sum[ls] + sum[rs];
}

void build(LL l, LL r, LL rt){
	if(l == r){
		sum[rt] = a[l];
		return ;
	}
	LL m = (l + r) >> 1;
	build(l,m,ls);
	build(m+1,r,rs);
	pushup(rt);
}

void update(LL L, LL R, LL l, LL r, LL rt){
	if(l == r){
		sum[rt] = floor(sqrt(sum[rt]));
		return ;
	}
	if(L <= l && r <= R && sum[rt] == r-l+1) return ; //当前区间内每个叶子节点均为1 
	LL m = (l + r) >> 1;
	if(L <= m) update(L,R,l,m,ls);
	if(R > m) update(L,R,m+1,r,rs);
	pushup(rt);
}

LL query(LL L, LL R, LL l, LL r, LL rt){
	if(L <= l && R >= r) return sum[rt];
	LL m = (l + r) >> 1;
	LL ans = 0;
	if(L <= m) ans += query(L,R,l,m,ls);
	if(R > m) ans += query(L,R,m+1,r,rs);
	return ans;
}

int main(){
	while(~scanf("%lld",&n)){
		memset(sum,0,sizeof(sum));
		for(int i = 1; i <= n; i ++)
			scanf("%lld",&a[i]);
		build(1,n,1);
		scanf("%lld",&m);
		LL t,x,y;
		printf("Case #%d:\n",++cas);
		while(m --){
			scanf("%lld%lld%lld",&t,&x,&y);
			if(x > y) swap(x,y);
			if(t){
				printf("%lld\n",query(x,y,1,n,1));
			}
			else{
				update(x,y,1,n,1);
			}
		}
		printf("\n");
	}
	return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值