2016 ACM-ICPC 亚洲区(青岛赛区)现场赛

A:hdu5982:

 

Relic Discovery

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 830    Accepted Submission(s): 661

 

 

Problem Description

Recently, paleoanthropologists have found historical remains on an island in the Atlantic Ocean. The most inspiring thing is that they excavated in a magnificent cave and found that it was a huge tomb. Inside the construction,researchers identified a large number of skeletons, and funeral objects including stone axe, livestock bones and murals. Now, all items have been sorted, and they can be divided into N types. After they were checked attentively, you are told that there are Ai items of the i-th type. Further more, each item of the i-th type requires Bi million dollars for transportation, analysis, and preservation averagely. As your job, you need to calculate the total expenditure.

 

 

Input

The first line of input contains an integer T which is the number of test cases. For each test case, the first line contains an integer N which is the number of types. In the next N lines, the i-th line contains two numbers Ai and Bi as described above. All numbers are positive integers and less than 101.

 

 

Output

For each case, output one integer, the total expenditure in million dollars.

 

 

Sample Input

 

1 2 1 2 3 4

 

 

Sample Output

 

14

 

 

Source

2016ACM/ICPC亚洲区青岛站-重现赛(感谢中国石油大学)

 

 

代码如下:

#include <bits/stdc++.h>
using namespace std;

int t,n,a,b;

int main(){
    scanf("%d",&t);
    while(t --){
        int sum = 0;
        scanf("%d",&n);
        for(int i = 0; i < n; i ++){
            scanf("%d%d",&a,&b);
            sum += a*b;
        }
        printf("%d\n",sum);
    }    
    return 0;
}

 

C:hdu5984

 

 

 

Pocky

 

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 815    Accepted Submission(s): 458

 

 

Problem Description

Let’s talking about something of eating a pocky. Here is a Decorer Pocky, with colorful decorative stripes in the coating, of length L.
While the length of remaining pocky is longer than d, we perform the following procedure. We break the pocky at any point on it in an equal possibility and this will divide the remaining pocky into two parts. Take the left part and eat it. When it is not longer than d, we do not repeat this procedure.
Now we want to know the expected number of times we should repeat the procedure above. Round it to 6 decimal places behind the decimal point.

 

 

Input

The first line of input contains an integer N which is the number of test cases. Each of the N lines contains two float-numbers L and d respectively with at most 5 decimal places behind the decimal point where 1 ≤ d, L ≤ 150.

 

 

Output

For each test case, output the expected number of times rounded to 6 decimal places behind the decimal point in a line.

 

 

Sample Input

 

6 1.0 1.0 2.0 1.0 4.0 1.0 8.0 1.0 16.0 1.0 7.00 3.00

 

 

Sample Output

 

0.000000 1.693147 2.386294 3.079442 3.772589 1.847298

 

 

Source

2016ACM/ICPC亚洲区青岛站-重现赛(感谢中国石油大学)

 

 

 

思路:参考该博客https://www.oyohyee.com/post/HDU/5984.html

 

#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>
using namespace std;

int n;
double l,d;

int main(){
	scanf("%d",&n);
	while(n --){
		scanf("%lf%lf",&l,&d);
		if(l <= d) printf("0.000000\n");
		else printf("%.6lf\n",log(l/d) + 1);
	}
	return 0;
}

 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值