hdu 5883 The Best Path 2016ACM/ICPC青岛赛区网络赛1006

Problem Description
Alice is planning her travel route in a beautiful valley. In this valley, there are  N  lakes, and  M  rivers linking these lakes. Alice wants to start her trip from one lake, and enjoys the landscape by boat. That means she need to set up a path which go through every river exactly once. In addition, Alice has a specific number ( a1,a2,...,an ) for each lake. If the path she finds is  P0P1...Pt , the lucky number of this trip would be  aP0XORaP1XOR...XORaPt . She want to make this number as large as possible. Can you help her?
 

Input
The first line of input contains an integer  t , the number of test cases.  t  test cases follow.

For each test case, in the first line there are two positive integers  N (N100000)  and  M (M500000) , as described above. The  i -th line of the next  N  lines contains an integer  ai(i,0ai10000)  representing the number of the  i -th lake.

The  i -th line of the next  M  lines contains two integers  ui  and  vi  representing the  i -th river between the  ui -th lake and  vi -th lake. It is possible that  ui=vi .
 

Output
For each test cases, output the largest lucky number. If it dose not have any path, output "Impossible".
 

Sample Input
  
  
2 3 2 3 4 5 1 2 2 3 4 3 1 2 3 4 1 2 2 3 2 4
 

Sample Output
  
  
2 Impossible

因为要求每条边都只走一遍。所以这是个一笔画问题

度为奇数的点>2则不可行

若度为奇数的点=2

那么一定是一个奇点入一个奇点出

首位次数为(deg+1)/2,中间点次数为deg/2

若度为奇数的点=0

那么一定是同一个点作为起点和终点

其他点次数为deg/2

然后枚举起点,起点计算次数多一次,最后取最大值即可

#include<map>
#include<cmath>
#include<queue>
#include<vector>
#include<cstdio>
#include<string>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
int indeg[100001];
int a[100001],s[1000001],t[1000001];
int main()
{
	int T;
	scanf("%d",&T);
	while(T>0)
	{
		T--;
		int n,m;
		scanf("%d%d",&n,&m);
		int i,j;
		for(i=1;i<=n;i++)
			scanf("%d",&a[i]);
		memset(indeg,0,sizeof(indeg));
		for(i=1;i<=m;i++)
		{
			scanf("%d%d",&s[i],&t[i]);
			indeg[s[i]]++;
			indeg[t[i]]++;
		}
		int sum=0;
		for(i=1;i<=n;i++)
			sum+=indeg[i]%2;
		if(sum>2)
			printf("Impossible\n");
		else
		{
			if(sum==0)
			{
				int ans=0;
				for(i=1;i<=n;i++)
				{
					for(j=1;j<=indeg[i]/2;j++)
						ans^=a[i];
				}
				int maxx=0;
				for(i=1;i<=n;i++)
					maxx=max(maxx,(ans^a[i]));
				printf("%d\n",maxx);
			}
			else
			{
				int ans=0;
				for(i=1;i<=n;i++)
				{
					if(indeg[i]%2==0)
					{
						for(j=1;j<=indeg[i]/2;j++)
							ans^=a[i];
					}
					else
					{
						for(j=1;j<=indeg[i]/2+1;j++)
							ans^=a[i];
					}
				}
				printf("%d\n",ans);
			}
		}
	}
	return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值