UVA133 The Dole Queue

Description

Download as PDF

In a serious attempt to downsize (reduce) the dole queue, The New National Green Labour Rhinoceros Party has decided on the following strategy. Every day all dole applicants will be placed in a large circle, facing inwards. Someone is arbitrarily chosen as number 1, and the rest are numbered counter-clockwise up to N (who will be standing on 1's left). Starting from 1 and moving counter-clockwise, one labour official counts off k applicants, while another official starts from N and moves clockwise, counting m applicants. The two who are chosen are then sent off for retraining; if both officials pick the same person she (he) is sent off to become a politician. Each official then starts counting again at the next available person and the process continues until no-one is left. Note that the two victims (sorry, trainees) leave the ring simultaneously, so it is possible for one official to count a person already selected by the other official.

Input

Write a program that will successively read in (in that order) the three numbers (N, k and m; k, m > 0, 0 < N < 20) and determine the order in which the applicants are sent off for retraining. Each set of three numbers will be on a separate line and the end of data will be signalled by three zeroes (0 0 0).

Output

For each triplet, output a single line of numbers specifying the order in which people are chosen. Each number should be in a field of 3 characters. For pairs of numbers list the person chosen by the counter-clockwise official first. Separate successive pairs (or singletons) by commas (but there should not be a trailing comma).

Sample input

10 4 3
0 0 0

Sample output

tex2html_wrap_inline34 4 tex2html_wrap_inline34 8, tex2html_wrap_inline34 9 tex2html_wrap_inline34 5, tex2html_wrap_inline34 3 tex2html_wrap_inline34 1, tex2html_wrap_inline34 2 tex2html_wrap_inline34 6, tex2html_wrap_inline50 10, tex2html_wrap_inline34 7

where tex2html_wrap_inline50 represents a space.


利用数组来储存数据,并用求余(%)操作来循环遍历数组。

假如数组个数为n,下标从0开始储存数据,开始遍历位置下标为start,步长为step,则在此题目中逆时针遍历时下一位置下标为 start=(start+step)%n,顺时针遍历时下一位置下标为 start=(start-step+n)%n,因为离开的人不计算,所以要一步一步的遍历,具体见代码。


#include<stdio.h>
#include<string.h>

int a[20];

int main()
{
	int n, k, m;
	while (scanf("%d%d%d", &n, &k, &m) == 3 && n&&k&&m)
	{
		memset(a, 0, sizeof(a));
		for (int i = 0;i<n;i++)
			a[i] = i + 1;

		int p1 = 0, p2 = n - 1;
		int leavePerson = 0;  //离开的人数
		m--;  //m,k为步长,因为是从当前位置开始数起,所以两个步长均需减一
		k--;
		while (leavePerson != n)
		{
			int tk = k, tm = m;  //保存k,m的值

			while (tk--)
			{
				do {
					p1 = (p1 + 1) % n;
				} while (a[p1] == 0);  //找下一个不为零的位置
			}

			while (tm--)
			{
				do {
					p2 = (p2 - 1 + n) % n;
				} while (a[p2] == 0);  //找下一个不为零的位置
			}


			printf("%3d", a[p1]);
			leavePerson++;
			a[p1] = 0;

			if (p2 != p1)
			{
				printf("%3d", a[p2]);
				leavePerson++;
				a[p2] = 0;
				do {
					p2 = (p2 - 1 + n) % n;
				} while (a[p2] == 0&&leavePerson!=n);
			}
			else
            {
                do {
					p2 = (p2 - 1 + n) % n;
				} while (a[p2] == 0&&leavePerson!=n);
            }
            do {
				p1 = (p1 + 1) % n;
			} while (a[p1] == 0&&leavePerson!=n);
			
			if (leavePerson != n)
				printf(",");
		}
		printf("\n");
	}
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
用C++编写程序,实现以下问题2、题目ID Codes(POJ1146) Time Limit: 1000MS Memory Limit: 10000K 描述: It is 2084 and the year of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure--all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people's movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly. The complicated way in which the code is imprinted into the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set. For example, suppose it is decided that a code will contain exactly 3 occurrences of a', 2 of b' and 1 of c', then three of the allowable 60 codes under these conditions are: abaabc abaacb ababac These three codes are listed from top to bottom in alphabetic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and print the successor code if one exists or the message No Successor' if the given code is the last in the sequence for that set of characters. 输入: Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated by a line consisting of a single #. 输出: Output will consist of one line for each code read containing the successor code or the words 'No Successor'. 样例输入 abaacb cbbaa # 样例输出 ababac No Successor
最新发布
05-22

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值