hdu1062Text Reverse

传送门:http://acm.hdu.edu.cn/showproblem.php?pid=1062
字符串翻转问题。
Ignatius likes to write words in reverse way. Given a single line of text which is written by Ignatius, you should reverse all the words and then output them.

Input
The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow.
Each test case contains a single line with several words. There will be at most 1000 characters in a line.

Output
For each test case, you should output the text which is processed.

Sample Input
3
olleh !dlrow
m'I morf .udh
I ekil .mca
 
Sample Output
hello world!
I'm from hdu.
I like acm.

//思路重开一个字符数组,存字符。每一次遇到空格,就倒序输出,顺便输出一个空格。
最后一个单词的话就单独拿出来,不输出空格。

#include<iostream>
#include<cstdio>
#include<cstring>
#include<string>
#include<stdio.h>
using namespace std;
int t;
char c[10005];
char s[10005];
int main(){
    cin>>t;
    getchar();
    while(t--){
    gets(c);
    int len=strlen(c);
    int i=0,top=0;
    for(;i<len;i++){
        if(c[i]!=' '){
            s[top++]=c[i];
        }
        else {
            for(int j=top-1;j>=0;j--){
                printf("%c",s[j]);
                //倒序输出
            }
            top=0;//重新计数,这是个点,每次输出完后在重新计数,再倒序输出。
            printf(" ");
        }
        if(i==len-1){
        //最后一个单独拿出来
            for(int j=top-1;j>=0;j--){
                printf("%c",s[j]);
            }
        }
    }
        printf("\n");
    }
    return 0;
}
//也可以用栈来做,栈的特点就是后进先出。
#include<stdio.h>
#include<stack>
using namespace std;
int main()
{
	int n;
    char ch;
	scanf("%d",&n);
	getchar();//清除缓冲区,吞回车
	while(n--)
	{
		stack<char> s; 
		while(true)
		{
			ch=getchar(); /*压栈时,一次压入一个字符*/
            if(ch==' '||ch=='\n'||ch==EOF)
			{
				while(!s.empty())
				{
					printf("%c",s.top()); 
					s.pop(); /*清除栈顶元素*/
				}
				if(ch=='\n'||ch==EOF)  
					break;  /*绝对不能少,控制输出结束*/
				printf(" ");
			}
			else
				s.push(ch);
		}
		printf("\n");
	}
	return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值