有效的括号

题目描述

给定一个只包括 '(',')','{','}','[',']' 的字符串,判断字符串是否有效。

有效字符串需满足:

  1. 左括号必须用相同类型的右括号闭合。
  2. 左括号必须以正确的顺序闭合。

注意空字符串可被认为是有效字符串。

输入

多组数据

每组是一个由'(',')','{','}','[',']' 组成的括号序列

每组字符串长度不超过50。

输出

如果有效输出true, 否则输出false。

样例输入

()
()[]{}
(]
([)]
{[]}

样例输出

true
true
false
false
true
#include<iostream>
using namespace std;
#include<string.h>
class Stack{
private:
      char *p;
      int top;
      int maxsize;
public:
      Stack(int size)
      {
            top=-1;
            maxsize=size;
            p=new char[size];
      }
      bool IsEmpty(){return  (top==-1)?true:false;}
      bool  IsFull(){return (top==maxsize-1)?true:false;}
      bool Push(char &x)
      {
      if(IsFull())
            return false;
            p[++top]=x;
      return true;
      }
      bool  Pop(char &x)
      {
            if(IsEmpty())
            return  false;
      x=p[top--];
      }

};

int main()
{
     char str[51];
     while(cin>>str)
     {
     Stack *p1=new Stack(50);
     Stack  *p2=new Stack(50);
     char current=0;
     for(int i=0;i<strlen(str);i++)
     {
           if(str[i]!=current)
          {
            p1->Push(str[i]);
                  if(current!=0)
                  p2->Push(current);
           switch(str[i])
           {
         case'[':
            current=']';
            break;
         case'{':
            current='}';
            break;
         case'(':
            current=')';
            break;
           }
          }
         else
          {
           char elem;
         p1->Pop(elem);
         p2->Pop(current);
          }
     }
     if(p1->IsEmpty())
      cout<<"true"<<endl;
     else
      cout<<"false"<<endl;
     delete p1;
     delete p2;
     }
      return 0;

}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

深度学习推荐算法

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值