最小栈

题目描述

设计一个支持 push,pop,top 操作,并能在常数时间内检索到最小元素的栈。

  • push(x) -- 将元素x推入栈中。
  • pop() -- 删除栈顶的元素。
  • top() -- 获取栈顶元素。
  • getMin() -- 检索栈中的最小元素。

输入

第一行一个整数q,表示操作数量。

接下来q行,每行为题目四中操作的一种。

分别为

push x

pop 

top

getMin


数据范围:q<=100000, |x|<=1000000000。

题目保证在执行pop,top,getMin操作时栈不为空。

输出

输出top和getMin操作时的答案

每个数占一行

样例输入

7
push -2
push 0
push -3
getMin
pop
getMin
top


样例输出

-3
-2
0
#include<iostream>
using namespace std;
#include<string>
class Stack{
private:
      int *p;
      int top;
      int maxsize;
public:
      Stack(int size)
      {
            top=-1;
            maxsize=size;
            p=new int[size];
      }
      bool IsEmpty(){return  (top==-1)?true:false;}
      bool  IsFull(){return (top==maxsize-1)?true:false;}
      bool Push(int &x)
      {
      if(IsFull())
            return false;
            p[++top]=x;
      return true;
      }
      bool  Pop(int &x)
      {
            if(IsEmpty())
            return  false;
      x=p[top--];
      }
      bool  Top(int &x)
      {
            if(IsEmpty())
                  return false;
            x=p[top];
            return true;
      }
      bool Min(int &x)
      {
            if(IsEmpty())
                  return false;
         x=p[0];
         for(int i=1;i<=top;i++)
            if(p[i]<x)
            x=p[i];
         return true;
      }

};

int main()
{
    int q,x;
    string s,s1="push",s2="pop",s3="top",s4="getMin";
    Stack *p=new Stack(300);
    cin>>q;
    for(int i=0;i<q;i++)
    {
       cin>>s;
         if(s==s1)
         {
            cin>>x;
            p->Push(x);
         }
         if(s==s2)
         {
             p->Pop(x);
         }
         if(s==s3)
         {
               p->Top(x);
               cout<<x<<endl;
         }
         if(s==s4)
         {
               p->Min(x);
               cout<<x<<endl;
         }
    }
    delete p;
      return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Coder_by

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值