小孩报数问题


题目描述

有N个小孩围成一圈,给他们从1开始依次编号,现指定从第W个开始报数,报到第S个时,该小孩出列,然后从下一个小孩开始报数,仍是报到S个出列,如此重复下去,直到所有的小孩都出列(总人数不足S个时将循环报数),求小孩出列的顺序。

输入

第一行输入小孩的人数N(N<=64) 
接下来每行输入一个小孩的名字(人名不超过15个字符) 
最后一行输入W,S (W < N),用逗号","间隔

输出

按人名输出小孩按顺序出列的顺序,每行输出一个人名

样例输入

5
Xiaoming
Xiaohua
Xiaowang
Zhangsan
Lisi
2,3

样例输出

Zhangsan
Xiaohua
Xiaoming
Xiaowang
Lisi

#include<iostream>
#include<string>
using namespace std;
int main()
{
      struct  child
      {
            string name;
            child *next;
      };
    int count,start,m;
    char ch;
    cin>>count;
    child *head = NULL;
    head = new child;
      cin>>head->name;

    child *p = head;
    for(int i = 0; i <count - 1; i++)
      {
    p->next = new child;
    p=p->next;
    cin>>p->name;
    }
     p->next = head;
    cin >> start>>ch>>m;

    for(int i = 1; i < start; i++)
    head = head->next;

    while(head->next != head){
    child *father=NULL;
    for(int i = 1; i < m; i++){
        father = head;
        head = head->next;
    }

   father->next = head->next;
    cout << head->name << endl;
    delete head;
    head = father->next;

    }
    cout << head->name << endl;
    delete head;
    
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Coder_by

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值