NYoj 156 Hangover

Hangover
时间限制:1000 ms | 内存限制:65535 KB
难度:1
描述
How far can you make a stack of cards overhang a table? If you have one card, you can create a maximum overhang of half a card length. (We’re assuming that the cards must be perpendicular to the table.) With two cards you can make the top card overhang the bottom one by half a card length, and the bottom one overhang the table by a third of a card length, for a total maximum overhang of 1/2 + 1/3 = 5/6 card lengths. In general you can make n cards overhang by 1/2 + 1/3 + 1/4 + … + 1/(n + 1) card lengths, where the top card overhangs the second by 1/2, the second overhangs tha third by 1/3, the third overhangs the fourth by 1/4, etc., and the bottom card overhangs the table by 1/(n + 1). This is illustrated in the figure below.

输入
The input consists of one or more test cases, followed by a line containing the number 0.00 that signals the end of the input. Each test case is a single line containing a positive floating-point number c whose value is at least 0.01 and at most 5.20; c will contain exactly three digits.
输出
For each test case, output the minimum number of cards necessary to achieve an overhang of at least c card lengths. Use the exact output format shown in the examples.
样例输入
1.00
3.71
0.04
5.19
0.00
样例输出
3 card(s)
61 card(s)
1 card(s)
273 card(s)

这个题是难度不大。但有好几个要注意的点。首先是判定出界的条件我觉得很巧。可能接触的还是太少。>=时出界。还有就是我写的时候一直出错,最后才注意到,我定义的sum是double,但接收的数字却是%f,这两个比较是没法比较的。不知道是编译器的原因还是没学好,这一地方要一一的对应。算是知道了新的东西。

#include"cstdio"
#include"cstring"
#include"cmath"
#include"algorithm"
using namespace std;  

int main ()
{
    int t;
    int i, j, k, m, x, y, p;
    double n;
    while(scanf("%lf",&n)!=EOF)
    {
        if(n==0)
        return 0;
        double sum=0;
        for(i=2;;i++)
        {
            sum=sum+1.0/i;
            if(sum>=n)
            {
                printf("%d card(s)\n",i-1);
                break;
            }

        }
    }

    return 0;
}    
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值